docker-compose设置容器中sysctl(容器中执行sysctl -p报错 sysctl: error setting key ‘xxx‘: Read-only file system)

1. 错误描述

  • 需求:修改容器可用端口范围
  • 操作:将容器的/etc/sysctl.conf 文件挂载出来,并配置可用端口范围
net.ipv4.ip_local_port_range = 1024 65535
  • 报错
    端口范围的配置并没有生效。进入容器,发现文件被正常挂载了。于是手动执行一下,报错如下:
bash-5.0$ sudo sysctl -p
sysctl: error setting key 'net.ipv4.ip_local_port_range': Read-only file system
sysctl: error setting key 'fs.file-max': Read-only file system
sysctl: error setting key 'fs.nr_open': Read-only file system

2. 原因

docker 限制了对容器中 /proc/sys 的访问

3. 解决(推荐)

docker-compose 加入了sysctls选项来解决这个问题

  emqx:
    image: "emqx/emqx:4.3.11"
    sysctls:
     - net.ipv4.ip_local_port_range=1024 65535

*另一个方法(不推荐)

用特权模式启动

  • 修改docker-compose.yml 文件
version: "3.1"
services:
 emqx:
   image: "emqx/emqx:4.3.11"
   privileged: true #加入这一行
  • 启动容器后,在容器中执行:
sysctl -p
  • 不推荐原因:
    • 重启就没了
    • 容器获得了过高的权限

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
【社区内容提示】社区部分内容疑似由AI辅助生成,浏览时请结合常识与多方信息审慎甄别。
平台声明:文章内容(如有图片或视频亦包括在内)由作者上传并发布,文章内容仅代表作者本人观点,简书系信息发布平台,仅提供信息存储服务。

相关阅读更多精彩内容

友情链接更多精彩内容