we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
Output
for each case, you should the result of y+f(x) on a line.
Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3
Sample Output
19
18
10
-17
-14
-4
问题来源:https://vjudge.net/problem/HDU-2055
问题分析:fx对64和96分别求余,然后再加y。
代码分析:先判断要求求的次数,然后输入x,y,对x求余。然后加起来。
AC通过的代码:
#include<iostream>
using namespace std;
int main()
{
char x; int y; int n; int fx;
cin >> n;
while (n--)
{
cin >> x >> y;
if (x >= 65 && x <= 90)
{
fx = x % 64;
cout << y + fx << endl;
}
if (x >= 97 && x <= 122)
{
fx = -(x % 96);
cout << y +fx << endl;
}
}
return 0;
}