网络端口地址转换 NAPT 配置

你是某公司的网络管理员,公司办公网需要接入互联网,公司只向 ISP 申请了一条专线,该专线分配了一个公司 IP 地址,配置实现全公司的主机都能访问外网。

技术原理

NAT 将网络划分为内部网络和外部网络两部分,局域网主机利用 NAT 访问网络时,是将局域网内部的本地地址转换为全局地址(互联网合法的 IP 地址)后转发数据包;

NAT 分为两种类型:NAT(网络地址转换)和 NAPT(网络端口地址转换 IP 地址对应一个全局地址)。

NAPT:使用不同的端口来映射多个内网 IP 地址到一个指定的外网 IP 地址,多对一。

NAPT 采用端口多路复用方式。内部网络的所有主机均可共享一个合法外部 IP 地址实现对 Internet 的访问,从而可以最大限度地节约 IP 地址资源。同时,又可隐藏网络内部的所有主机,有效避免来自 Internet 的攻击。因此,目前网络中应用最多的就是端口多路复用方式。

ISP(Internet Service Provider),互联网服务提供商,即向广大用户综合提供互联网接入业务、信息业务和增值业务的电信运营商。ISP是经国家主管部门批准的正式运营企业,享受国家法律保护。

实验步骤

新建 Packet Tracer 拓扑图

(1)R1 为公司出口路由器,其与 ISP 路由器之间通过 V.35 电缆串口连接,DCE 端连接在 R1 上,配置其时钟频率 64000;

(2)配置 PC 机、服务器及路由器接口 IP 地址;

(3)在各路由器上配置静态路由协议,让 PC 间能相互 Ping 通;

(4)在 R1 上配置 NAPT。

(5)在 R1 上定义内外网络接口。

(6)验证主机之间的互通性。

实验设备

PC 2 台;Server-PT 1 台;Switch_2950-24 1 台 Router-PT 2 台;直通线;交叉线;DCE串口线

PC1

192.168.1.2

255.255.255.0

192.168.1.1

PC2

192.168.1.3

255.255.255.0

192.168.1.1

Server

200.1.2.2

255.255.255.0

200.1.2.1

R1

en

conf t

host R1

int fa 0/0

ip address 192.168.1.1 255.255.255.0

no shutdown

int s 2/0

ip address 200.1.1.1 255.255.255.0

no shutdown

clock rate 64000

R2

en

conf t

host R2

int s 2/0

ip address 200.1.1.2 255.255.255.0

no shutdown

int fa 0/0

ip address 200.1.2.1 255.255.255.0

no shutdown

R1

exit

ip route 200.1.2.0 255.255.255.0 200.1.1.2

R2

exit

ip route 192.168.1.0 255.255.255.0 200.1.1.1

end

show ip route

PC1

CMD

ping 200.1.2.2 (success)

Web 浏览器

http://200.1.2.2 (success)

R1

int fa 0/0

ip nat inside

int s 2/0

ip nat outside

exit

access-list 1 permit 192.168.1.0 0.0.0.255

ip nat pool jaking 200.1.1.3 200.1.1.3 netmask 255.255.255.0 #设置名称为jaking的地址池,起始和终止IP都是200.1.1.3

ip nat inside source list 1 pool jaking overload (无 overload 表示多对多,有 overload 表示多对一)

end

show ip nat translations(无结果)

PC1

Web 浏览器

http://200.1.2.2 (success)

R1

show ip nat translations(有 1 个结果)

PC2

Web 浏览器

http://200.1.2.2 (success)

R1

show ip nat translations(有 2 个结果)

实战演练

R1

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>en

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host R1

R1(config)#int fa 0/0

R1(config-if)#ip add 192.168.1.1 255.255.255.0

R1(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#int s 2/0

R1(config-if)#ip add 200.1.1.1 255.255.255.0

R1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down

R1(config-if)#clock rate 64000

R1(config-if)#

R2

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>en

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host R2

R2(config)#int s 2/0

R2(config-if)#ip add 200.1.1.2 255.255.255.0

R2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

R2(config-if)#int fa 0/0

R2(config-if)#ip add 200.1.2.1 255.255.255.0

R2(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#

R1

R1(config-if)#exit

R1(config)#ip route 200.1.2.0 255.255.255.0 200.1.1.2

R2

R2(config-if)#exit

R2(config)#ip route 192.168.1.0 255.255.255.0 200.1.1.1

R2(config)#end

R2#

%SYS-5-CONFIG_I: Configured from console by console

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

      i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

      * - candidate default, U - per-user static route, o - ODR

      P - periodic downloaded static route

Gateway of last resort is not set

S    192.168.1.0/24 [1/0] via 200.1.1.1

C    200.1.1.0/24 is directly connected, Serial2/0

C    200.1.2.0/24 is directly connected, FastEthernet0/0

PC1

CMD

ping 200.1.2.2 (success)

PC>ipconfig

IP Address......................: 192.168.1.2

Subnet Mask.....................: 255.255.255.0

Default Gateway.................: 192.168.1.1

PC>ping 200.1.2.2

Pinging 200.1.2.2 with 32 bytes of data:

Request timed out.

Reply from 200.1.2.2: bytes=32 time=24ms TTL=126

Reply from 200.1.2.2: bytes=32 time=25ms TTL=126

Reply from 200.1.2.2: bytes=32 time=20ms TTL=126

Ping statistics for 200.1.2.2:

    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

Approximate round trip times in milli-seconds:

    Minimum = 20ms, Maximum = 25ms, Average = 23ms

PC>ping 200.1.2.2

Pinging 200.1.2.2 with 32 bytes of data:

Reply from 200.1.2.2: bytes=32 time=25ms TTL=126

Reply from 200.1.2.2: bytes=32 time=20ms TTL=126

Reply from 200.1.2.2: bytes=32 time=23ms TTL=126

Reply from 200.1.2.2: bytes=32 time=25ms TTL=126

Ping statistics for 200.1.2.2:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 20ms, Maximum = 25ms, Average = 23ms

Web 浏览器

http://200.1.2.2 (success)

PC2

CMD

ping 200.1.2.2 (success)

PC>ipconfig

IP Address......................: 192.168.1.3

Subnet Mask.....................: 255.255.255.0

Default Gateway.................: 192.168.1.1

PC>ping 200.1.2.2

Pinging 200.1.2.2 with 32 bytes of data:

Reply from 200.1.2.2: bytes=32 time=31ms TTL=126

Reply from 200.1.2.2: bytes=32 time=17ms TTL=126

Reply from 200.1.2.2: bytes=32 time=19ms TTL=126

Reply from 200.1.2.2: bytes=32 time=23ms TTL=126

Ping statistics for 200.1.2.2:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 17ms, Maximum = 31ms, Average = 22ms

Web 浏览器

http://200.1.2.2 (success)

R1

R1(config)#int fa 0/0

R1(config-if)#ip nat inside

R1(config-if)#int s 2/0

R1(config-if)#ip nat outside

R1(config-if)#exit

R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255

R1(config)#ip nat pool jaking 200.1.1.3 200.1.1.3 netmask 255.255.255.0

R1(config)#ip nat inside source list 1 pool jaking overload

R1(config)#end

R1#

%SYS-5-CONFIG_I: Configured from console by console

R1#show ip nat translations

R1#

PC1

Web 浏览器

http://200.1.2.2 (success)

R1

show ip nat translations(有 1 个结果)

R1#show ip nat translations

Pro  Inside global    Inside local      Outside local      Outside global

tcp 200.1.1.3:1026    192.168.1.2:1026  200.1.2.2:80      200.1.2.2:80

PC2

Web 浏览器

http://200.1.2.2 (success)

R1

show ip nat translations(有 2 个结果)

R1#show ip nat translations

Pro  Inside global    Inside local      Outside local      Outside global

tcp 200.1.1.3:1026    192.168.1.2:1026  200.1.2.2:80      200.1.2.2:80

tcp 200.1.1.3:1024    192.168.1.3:1026  200.1.2.2:80      200.1.2.2:80

总结

至此,用思科模拟器进行网络端口地址转换 NAPT 配置完毕。

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 214,922评论 6 497
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,591评论 3 389
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 160,546评论 0 350
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,467评论 1 288
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,553评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,580评论 1 293
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,588评论 3 414
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,334评论 0 270
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,780评论 1 307
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,092评论 2 330
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,270评论 1 344
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,925评论 5 338
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,573评论 3 322
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,194评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,437评论 1 268
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,154评论 2 366
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,127评论 2 352