POJ2251——Dungeon Master

Problem

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#
#####
#####
##.##
##...
#####
#####
#.###
####E
1 3 3
S##
#E#
###
0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!


思路

迷宫最短路问题,只不过是三维的,写起来略复杂。

代码

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
char maze[31][31][31];
int vis[31][31][31];
int x, y, z;
int dx[6] = {0,0,0,0,1,-1};
int dy[6] = {0,0,1,-1,0,0};
int dz[6] = {1,-1,0,0,0,0};
int sx, sy, sz;
int ex, ey, ez;
struct Point  {
    int x, y, z,step;
    Point(int x,int y,int z):x(x),y(y),z(z),step(0){};
    Point(){};
};

int BFS()  {
    memset(vis,0,sizeof(vis));
    queue<Point> q;
    Point node(sx,sy,sz), t;
    q.push(node);
    vis[sx][sy][sz] = 1;
    while(!q.empty())  {
        node = q.front();
        q.pop();
        for(int i = 0; i < 6; i++) {
            t = node;  t.x += dx[i];  t.y += dy[i];  t.z += dz[i];
            t.step++;
            if(t.x == ex && t.y == ey && t.z == ez)
                return t.step;
            if(t.x < 1 || t.x > x || t.y < 1 || t.y > y || t.z < 1 || t.z > z || !maze[t.x][t.y][t.z] || vis[t.x][t.y][t.z])
                continue;
            else  {
                vis[t.x][t.y][t.z] = 1;
                q.push(t);
            }
        }
    }
    return -1;
}

int main()  {
    char str[31];
    while(scanf("%d %d %d", &x, &y, &z) ==3 && (x+y+z))  {
        memset(maze,1,sizeof(maze));
        for(int i = 1; i <= x; i++)  {
            for(int j = 1; j <= y; j++)  {
                scanf("%s",str + 1);
                for(int k = 1; k <= z; k++)  {
                    if(str[k] == 'S')  {  sx = i;  sy = j; sz = k;  }
                    if(str[k] == 'E')  {  ex = i;  ey = j;  ez = k;  }
                    if(str[k] == '#')  maze[i][j][k] = 0;
                }
            }
        }
        if(BFS() == -1)
            printf("Trapped!\n");
        else
            printf("Escaped in %d minute(s).\n", BFS());
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 213,711评论 6 493
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,079评论 3 387
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 159,194评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,089评论 1 286
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,197评论 6 385
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,306评论 1 292
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,338评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,119评论 0 269
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,541评论 1 306
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,846评论 2 328
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,014评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,694评论 4 337
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,322评论 3 318
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,026评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,257评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,863评论 2 365
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,895评论 2 351

推荐阅读更多精彩内容

  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,444评论 0 23
  • 莫道只如初见 故人心似离弦 闲愁这般入眉间 尘世几多愁怨 何叹秋风悲扇 平林新月寒蝉 世间惟有敬亭山 相看何曾相厌
    骊山语罢清宵半i阅读 309评论 1 4
  • 这是美国著名的摄影记者罗伯特·卡帕的一句话,这句话在网络上广为流传。 像蚂蚁一样工作。 这或许是我们协调工作与生活...
    香之兰儿阅读 730评论 0 0
  • 下午五点多,来了一场不及时的大雨,黑压压的天空总算是憋不住了,看着淅淅沥沥的小雨,眼前有点模糊,有点惆怅。 对于新...
    夜初微凉阅读 100评论 0 0
  • 井底之蛙安然于一口井,会觉得跳出一口井很困难深海之鲨遨游四方,无所畏惧的在大风大浪中漂流 面对困难与挫折, 有一些...
    Cloudya云阅读 685评论 0 0