通过consule进行配置:
# 设置系统的日期、时间和时区
<HUAWEI>clock timezone BJ add 08:00:00
<HUAWEI>clock datetime 08:00:00 2018-04-12
# 设置设备名称和管理IP地址
[~HUAWEI] system-view
[~HUAWEI] sysname Server
[*HUAWEI] commit
[~Server] interface meth 0/0/0
[*Server-MEth0/0/0] ip address x.x.x.x x
[*Server-MEth0/0/0] quit
# 设置Telnet用户的级别和认证方式
[*Server] undo telnet server disable // telnet enable
[*Server] user-interface vty 0 4
[*Server-ui-vty0-4] user privilege level 3
[*Server-ui-vty0-4] authentication-mode aaa
[*Server-ui-vty0-4] quit
[*Server] aaa
[*Server-aaa] local-user xxx password irreversible-cipher xxxxxx
[*Server-aaa] local-user xxx level 3
[*Server-aaa] local-user xxx service-type telnet
[*Server-aaa] commit
[~Server-aaa] quit
#配置Telnet登录设备
1.配置服务器的端口号以及使能服务器功能
[~HUAWEI] system-view
[~HUAWEI] sysname Telnet Server
[*HUAWEI] commit
[~Telnet Server] undo telnet server disable
[*Telnet Server] telnet server port xxxx
2.配置VTY用户界面的相关参数
# 配置VTY用户界面的最大个数。
[*Telnet Server] user-interface maximum-vty 8
[*Telnet Server] commit
# 配置允许用户登录设备的主机地址。
[*Telnet Server] acl 2001
[*Telnet Server-acl4-basic-2001] rule permit source x.x.x.x x
[*Telnet Server-acl4-basic-2001] rule deny source x.x.x.x x
[*Telnet Server-acl4-basic-2001] quit
[*Telnet Server] user-interface vty 0 7
[*Telnet Server-ui-vty0-7] acl 2001 inbound
# 配置VTY用户界面的用户验证方式。
[*Telnet Server-ui-vty0-7] authentication-mode aaa
[*Telnet Server-ui-vty0-7] quit
3.配置登录用户的相关信息
# 配置登录验证方式。
[*Telnet Server] aaa
[*Telnet Server-aaa] local-user xxx password irreversible-cipher xxxxxx
[*Telnet Server-aaa] local-user xxx service-type telnet
[*Telnet Server-aaa] local-user xxx level 3
[*Telnet Server-aaa] commit
[~Telnet Server-aaa] quit
2.在服务器端创建SSH用户。
# 配置VTY用户界面。
[~SSH Server] user-interface vty 0 4 //进入VTY 0~VTY 4用户界面视图
[~SSH Server-ui-vty0-4] authentication-mode aaa //配置登录用户界面的认证方式为AAA认证
[*SSH Server-ui-vty0-4] user privilege level 3 //配置用户级别为3
[*SSH Server-ui-vty0-4] protocol inbound ssh //配置VTY用户界面支持SSH协议
[*SSH Server-ui-vty0-4] quit
# 创建SSH用户xxx,配置其认证方式为password。
[*SSH Server] aaa
[*SSH Server-aaa] local-user xxx password irreversible-cipher xxxx //配置本地用户名和密码
[*SSH Server-aaa] local-user xxx level 3 //配置本地用户名的级别为3
[*SSH Server-aaa] local-user xxx service-type ssh //配置本地用户的服务方式为SSH
[*SSH Server-aaa] quit
[*SSH Server] ssh user xxx authentication-type password //配置SSH用户c的认证方式为密码认证
配置本地用户的服务类型
[~HUAWEI] system-view
[~HUAWEI] aaa
[~HUAWEI-aaa] local-user xxx@vipdomain password irreversible-cipher xxxx
[*HUAWEI-aaa] local-user xxx@vipdomain service-type telnet
[*HUAWEI-aaa] commit
开启FTP服务器功能
[~HUAWEI]system-view
[~HUAWEI] ftp server enable
[*HUAWEI] aaa
[*HUAWEI-aaa] local-user xxx password irreversible-cipher xxx
[*HUAWEI-aaa] local-user xxx evel 3
[*HUAWEI-aaa] local-user xxx service-type ftp //设置用户接入类型为ftp。
[*HUAWEI-aaa] local-user xxx ftp-directory flash: //设置用户FTP目录为flash:/
[*HUAWEI-aaa] commit
[~HUAWEI-aaa] return save
Warning: The current configuration will be written to the device. Continue? [Y/N]: y
# 交换机堆叠配置 (华为交换机)
堆叠原理
角色选举
堆叠建立时,成员交换机之间相互发送堆叠竞争报文。通过竞争,一台成为主交换机,负责管理整个堆叠系统;另一台则成为备交换机,作为主交换机的备份交换机。
主交换机选举规则如下(依次从第一条开始判断,直至找到最优的交换机才停止比较):
运行状态比较,最先完成启动的交换机优先竞争为主交换机。
堆叠优先级比较,堆叠优先级高的交换机优先竞争为主交换机。
软件版本比较,软件版本高的交换机优先竞争为主交换机。
主控板数量比较,有2块主控板的交换机比只有1块主控板的交换机优先竞争为主交换机。
桥MAC地址比较,桥MAC地址小的交换机优先竞争为主交换机。
配置冲突检测
堆叠建立时,如果主交换机上有备交换机的离线配置,则有可能产生配置冲突的情况。此时可能导致堆叠无法建立,主要的配置冲突场景如下:
对于主控板直连方式的堆叠:
备交换机所有的SIP口在主交换机上都有Shutdown配置。
对于业务板直连方式的堆叠:
端口配置合并时,同一堆叠端口下的堆叠物理成员端口数量超出规格限制。
备交换机所有的堆叠物理成员端口在主交换机上都有Shutdown或与堆叠冲突的配置。
备交换机的堆叠端口在主交换机上有Shutdown或与堆叠冲突的配置。
同一堆叠端口下的堆叠物理成员端口的类型不同。
#交换机堆叠配置
[~HUAWEI]system-view
[~HUAWEI] stack
[~HUAWEI-stack] stack member 1 //配置堆叠成员ID
[*HUAWEI-stack] stack priority 150 //配置堆叠优先级
[*HUAWEI-stack] stack domain 10 //配置堆叠域编号
[*HUAWEI-stack] stack link-type mainboard-direct //配置堆叠连接方式
[*HUAWEI-stack] quit
[*HUAWEI] commit
[~HUAWEI] port-group group1
[*HUAWEI-port-group-group1] group-member 10ge 1/0/1 to 10ge 1/0/2
[*HUAWEI-port-group-group1] group-member 10ge 2/0/1 to 10ge 2/0/2
[*HUAWEI-port-group-group1] shutdown //先将需要加入堆叠逻辑端口的物理口Shutdown
[*HUAWEI-port-group-group1] quit
[*HUAWEI] commit
[~HUAWEI] interface stack-port 1 //创建堆叠逻辑端口
[*HUAWEI-Stack-Port1] port member-group interface 10ge 1/0/1 to 1/0/2 //为堆叠逻辑端口添加成员端口
[*HUAWEI-Stack-Port1] port member-group interface 10ge 2/0/1 to 2/0/2
[*HUAWEI-Stack-Port1] quit
[*HUAWEI] commit
[~HUAWEI] port-group group1[~HUAWEI-port-group-group1] undo shutdown //打开被关闭的成员端口[*HUAWEI-port-group-group1] quit[*HUAWEI] commit[~HUAWEI] quit save //保存配置
Warning: The current configuration will be written to the device. Continue? [Y/N]: y
[~HUAWEI] stack
[~HUAWEI-stack] stack enable //使能堆叠功能
Warning: Make sure that one or more dual-active detection methods are configured once the conversion is complete and the device ente
rs the stack mode.
Current configuration will be converted to the next startup saved-configuration file of stack mode.
System will reboot. Continue? [Y/N]: y
[~HUAWEI]system-view
[~HUAWEI] stack
[~HUAWEI-stack] stack member 1 renumber 2 inherit-config //配置堆叠成员ID
Warning: The stack configuration of member ID 1 will be inherited to member ID 2 after the device resets. Continue? [Y/N]: y
[*HUAWEI-stack] stack member 1 priority 150 //配置堆叠优先级
[*HUAWEI-stack] stack member 1 domain 10 //配置堆叠域编号
[*HUAWEI-stack] quit
[*HUAWEI] commit
[~HUAWEI] port-group group1
[*HUAWEI-port-group-group1] group-member 10ge 1/0/1 to 10ge 1/0/4
[*HUAWEI-port-group-group1] shutdown //先将需要加入堆叠逻辑端口的物理口Shutdown
[*HUAWEI-port-group-group1] quit
[*HUAWEI] commit
[~HUAWEI] interface stack-port 1/1 //创建堆叠逻辑端口
[*HUAWEI-Stack-Port1/1] port member-group interface 10ge 1/0/1 to 1/0/2
[*HUAWEI-Stack-Port1/1] quit
[*HUAWEI] interface stack-port 1/2
[*HUAWEI-Stack-Port1/2] port member-group interface 10ge 1/0/3 to 1/0/4
[*HUAWEI-Stack-Port1/2] quit
[*HUAWEI] commit
[~HUAWEI] port-group group1
[~HUAWEI-port-group-group1] undo shutdown //打开被关闭的成员端口
[*HUAWEI-port-group-group1] quit
[*HUAWEI] commit[~HUAWEI] quitsave //保存配置
Warning:
The current configuration will be written to the device. Continue?
[Y/N]: y
reboot //重启设备
Warning: The system will reboot. Continue? [Y/N]: y
配置接口切换到三层模式单接口切换:接口视图下执行命令undo portswitch,配置接口切换到三层模式。缺省情况下,以太网接口处于二层模式。# 将接口10GE1/0/1切换为三层模式。
[~HUAWEI] system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] undo portswitch
[*HUAWEI-10GE1/0/1] commit
# 批量切换接口10GE1/0/1~10GE1/0/3到三层模式。
[~HUAWEI]system-view
[~HUAWEI] undo portswitch batch 10ge 1/0/1 to 1/0/3
[*HUAWEI] commit
# 配置管理接口METH0/0/0的IP地址。
[~HUAWEI]system-view
[~HUAWEI] interface meth 0/0/0
[~HUAWEI-MEth0/0/0] ip address 10.1.1.1 24
[*HUAWEI-MEth0/0/0] commit
# 配置子接口10GE1/0/1.1的IP地址,通过的报文外层Tag为100。
[~HUAWEI] system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] undo portswitch
[*HUAWEI-10GE1/0/1] quit
[*HUAWEI] interface 10ge 1/0/1.1
[*HUAWEI-10GE1/0/1.1] ip address 10.1.1.1 24
[*HUAWEI-10GE1/0/1.1] dot1q termination vid 100
[*HUAWEI-10GE1/0/1.1] commit
# 配置接口10GE1/0/1工作在自协商模式。
[~HUAWEI]system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] undo negotiation disable
[*HUAWEI-10GE1/0/1] commit
# 自协商模式下配置10GE1/0/1电接口速率为1000MBit/s。
[~HUAWEI]system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] speed auto 1000
[*HUAWEI-10GE1/0/1] commit
# 非自协商模式下配置10GE1/0/1电接口速率为1000MBit/s。
[~HUAWEI] system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] negotiation disable
[*HUAWEI-10GE1/0/1] speed 1000
[*HUAWEI-10GE1/0/1] commit
示例:开启接口10GE1/0/1的流量控制功能。
[~HUAWEI] system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] flow-control //开启流量控制功能,默认情况是关闭状态
[*HUAWEI-10GE1/0/1] commit
示例:开启接口10GE1/0/1的流量控制自协商功能。
[~HUAWEI] system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] undo negotiation disable //开启自协商功能,默认情况下是开启自协商功能
[*HUAWEI-10GE1/0/1] flow-control negotiation //开启流量控制自协商功能,默认情况下是关闭状态
[*HUAWEI-10GE1/0/1] commit
配置端口组
配置临时端口组:
[~HUAWEI]system-view
[~HUAWEI] port-group group-member 10ge 1/0/1 to 10ge 1/0/3
[~HUAWEI-port-group]
配置永久端口组:
[~HUAWEI] system-view
[~HUAWEI] port-group portgroup1
[*HUAWEI-port-group-portgroup1] group-member 10ge 1/0/1 to 10ge 1/0/3
[*HUAWEI-port-group-portgroup1] commit
配置端口隔离# 配置GE1/0/1的端口隔离功能。
[~HUAWEI] system-view
[~HUAWEI] interface ge 1/0/1
[~HUAWEI-GE1/0/1] port-isolate enable group 1
[*HUAWEI-GE1/0/1] quit
[*HUAWEI] commit
# 配置GE1/0/2的端口隔离功能。
[~HUAWEI] interface ge 1/0/2
[~HUAWEI-GE1/0/2] port-isolate enable group 1
[*HUAWEI-GE1/0/2] quit
[*HUAWEI] commit
配置子接口
[~HUAWEI] system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] undo portswitch // 将当前接口切换为三层模式
[*HUAWEI-10GE1/0/1] commit
[~HUAWEI-10GE1/0/1] quit
[~HUAWEI] interface 10ge 1/0/1.1 // 进入子接口视图
配置限制MAC地址学习功能# 配置接口10GE1/0/1最多允许学习30个MAC地址。
[~HUAWEI] system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] mac-address limit maximum 30
[*HUAWEI-10GE1/0/1] commit
# 配置VLAN 10最多允许学习20个MAC地址。
[~HUAWEI] system-view
[~HUAWEI] vlan 10
[*HUAWEI-vlan10] mac-address limit maximum 20
[*HUAWEI-vlan10] commit
# 配置10GE1/0/1~10GE1/0/3加入Eth-Trunk1,且工作模式为手工负载分担模式。
[~HUAWEI] system-view
[~HUAWEI] interface eth-trunk 1
[*HUAWEI-Eth-Trunk1] mode manual load-balance
[*HUAWEI-Eth-Trunk1] trunkport interface 10ge 1/0/1 to 1/0/3
[*HUAWEI-Eth-Trunk1] commit
# 配置10GE1/0/1~10GE1/0/3加入Eth-Trunk1,且工作模式为静态LACP模式。
[~HUAWEI]system-view
[~HUAWEI] interface eth-trunk 1
[*HUAWEI-Eth-Trunk1] mode lacp-static
[*HUAWEI-Eth-Trunk1] trunkport interface 10ge 1/0/1 to 1/0/3
[*HUAWEI-Eth-Trunk1] commit
# 配置10GE1/0/4~10GE1/0/6加入Eth-Trunk2,且工作模式为动态LACP模式。
[~HUAWEI]system-view
[~HUAWEI] interface eth-trunk 2
[*HUAWEI-Eth-Trunk2] mode lacp-dynamic
[*HUAWEI-Eth-Trunk2] trunkport interface 10ge 1/0/4 to 1/0/6
[*HUAWEI-Eth-Trunk2] commit
配置本地流量优先转发Eth-Trunk接口视图下,执行命令undo local-preference disable,使能Eth-Trunk接口流量本地优先转发功能。
[~HUAWEI] system-view
[~HUAWEI] interface eth-trunk 10
[*HUAWEI-Eth-Trunk10] undo local-preference disable
[*HUAWEI-Eth-Trunk10] commit
值越小,优先级越高。# 配置系统LACP优先级
[*HUAWEI] system-view
[~HUAWEI] lacp priority 10
[*HUAWEI] commit
# 配置接口10GE1/0/1的LACP优先级。
[*HUAWEI] system-view
[~HUAWEI] interface eth-trunk 1
[*HUAWEI-Eth-Trunk1] trunkport 10ge 1/0/1
[*HUAWEI-Eth-Trunk1] mode lacp-static //配置接口优先级前,需首先保证接口已经加入LACP模式的Eth-Trunk接口中
[*HUAWEI-Eth-Trunk1] quit
[*HUAWEI] interface 10ge 1/0/1
[*HUAWEI-10GE1/0/1] lacp priority 1
[*HUAWEI-10GE1/0/1] commit
不同速率的接口加入链路聚合组
# 配置10GE1/0/1和40GE1/0/1两种速率的接口加入Eth-Trunk1。
[~HUAWEI]system-view
[~HUAWEI] interface eth-trunk 1
[*HUAWEI-Eth-Trunk1] mode lacp-static
[*HUAWEI-Eth-Trunk1] lacp mixed-rate link enable
[*HUAWEI-Eth-Trunk1] trunkport 10ge 1/0/1
[*HUAWEI-Eth-Trunk1] trunkport 40ge 1/0/1
[*HUAWEI-Eth-Trunk1] commit
# 配置接口10GE1/0/1禁止VLAN 1报文通过。
[~HUAWEI]system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] port link-type trunk
[*HUAWEI-10GE1/0/1] undo port trunk allow-pass vlan 1
[*HUAWEI-10GE1/0/1] commit
配置接口的缺省VLAN ID缺省情况下,接口的缺省VLAN都是VLAN 1。
# 配置Access类型接口的缺省VLAN为VLAN 3。
[~HUAWEI]system-view
[~HUAWEI] vlan batch 3
[*HUAWEI] interface 10ge 1/0/1
[*HUAWEI-10GE1/0/1] port link-type access
[*HUAWEI-10GE1/0/1] port default vlan 3
[*HUAWEI-10GE1/0/1] commit
# 配置Trunk类型接口的缺省VLAN为VLAN 4。
[~HUAWEI]system-view
[~HUAWEI] vlan batch 4
[*HUAWEI] interface 10ge 1/0/1
[*HUAWEI-10GE1/0/1] port link-type trunk
[*HUAWEI-10GE1/0/1] port trunk pvid vlan 4
[*HUAWEI-10GE1/0/1] commit
# 配置Hybrid类型接口的缺省VLAN为VLAN 5。
[~HUAWEI]system-view
[~HUAWEI] vlan batch 5
[*HUAWEI] interface 10ge 1/0/1
[*HUAWEI-10GE1/0/1] port link-type hybrid
[*HUAWEI-10GE1/0/1] port hybrid pvid vlan 5
[*HUAWEI-10GE1/0/1] commit
#VLAN透传配置方法
# 配置access接口透传VLAN 2。
[~HUAWEI]system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] port link-type access
[*HUAWEI-10GE1/0/1] port default vlan 2
[*HUAWEI-10GE1/0/1] commit
# 配置trunk接口透传VLAN 2
[~HUAWEI]system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] port link-type trunk
[*HUAWEI-10GE1/0/1] port trunk allow-pass vlan 2
[*HUAWEI-10GE1/0/1] commit
# 配置hybrid接口以Untagged方式透传VLAN 2。
[~HUAWEI]system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] port link-type hybrid
[*HUAWEI-10GE1/0/1] port hybrid untagged vlan 2
[*HUAWEI-10GE1/0/1] commit
# 配置hybrid接口以Tagged方式透传VLAN 2。
[~HUAWEI] system-view
[~HUAWEI] interface 10ge 1/0/1
[~HUAWEI-10GE1/0/1] port link-type hybrid
[*HUAWEI-10GE1/0/1] port hybrid tagged vlan 2
[*HUAWEI-10GE1/0/1] commit
配置DHCP中继CE系列交换机DHCP中继常用配置如下:
[~HUAWEI] system-view
[~HUAWEI] dhcp enable //使能DHCP功能
[*HUAWEI] vlan batch 100
[*HUAWEI] interface vlanif 100
[*HUAWEI-Vlanif100] ip address 10.10.20.1 24
[*HUAWEI-Vlanif100] dhcp select relay //启动接口的DHCP中继功能
[*HUAWEI-Vlanif100] quit
[*HUAWEI] commit
[~HUAWEI] dhcp relay server group dhcpgroup1 //创建DHCP服务器组并进入DHCP服务器组视图
[*HUAWEI-dhcp-relay-server-group-dhcpgroup1] server 10.10.10.1 //向DHCP服务器组中添加DHCP服务器
[*HUAWEI-dhcp-relay-server-group-dhcpgroup1] quit
[*HUAWEI] commit
[~HUAWEI] interface vlanif 100
[~HUAWEI-Vlanif100] dhcp relay binding server group dhcpgroup1 //指定接口对应的DHCP服务器组
[*HUAWEI-Vlanif100] quit
[*HUAWEI] commit
配置DHCP服务器CE系列交换机DHCP服务器常用配置如下:
[~HUAWEI] system-view
[~HUAWEI] dhcp enable //全局使能DHCP功能
[*HUAWEI] commit
[~HUAWEI] ip pool pool1 //创建全局地址池,同时进入全局地址池视图
[*HUAWEI-ip-pool-pool1] gateway-list 10.1.1.1 //配置DHCP服务器全局地址池的出口网关地址
[*HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 255.255.255.128 //配置全局地址池可动态分配的IP地址范围
[*HUAWEI-ip-pool-pool1] commit
[~HUAWEI-ip-pool-pool1] quit
#配置DNS服务器的IP地址CE系列交换机DNS服务器IP地址的配置如下:
[~HUAWEI] system-view
[~HUAWEI] ip pool pool1 //创建全局地址池,同时进入全局地址池视图
[*HUAWEI-ip-pool-pool1] dns-list 10.1.1.2
[*HUAWEI-ip-pool-pool1] commit
[~HUAWEI-ip-pool-pool1] quit
#排除不参与自动分配的IP地址
[~HUAWEI]system-view
[~HUAWEI] ip pool pool1
[*HUAWEI-ip-pool-pool1] gateway-list 10.1.1.1
[*HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 24
[*HUAWEI-ip-pool-pool1] excluded-ip-address 10.1.1.100 10.1.1.200
[*HUAWEI-ip-pool-pool1] commit
[~HUAWEI-ip-pool-pool1] quit
####生成树(STP)#############
配置思路
采用以下思路配置STP功能:
配置环网中的设备生成树协议工作在STP模式。
配置根桥和备份根桥设备。
配置端口的路径开销值,实现将该端口阻塞。
使能STP,实现破除环路。
操作步骤:
1、配置环网中的设备生成树协议工作在STP模式。SwitchB、SwitchC和SwitchD的配置与SwitchA差不多
[~HUAWEI]system-view
[~HUAWEI]sysnameSwitchA
[*HUAWEI]commit
[~SwitchA]stp mode stp
[*SwitchA]commit
配置根桥和备份根桥。
# 配置SwitchA为根桥。
[~SwitchA] stp root primary
[*SwitchA] commit
# 配置SwitchB为备份根桥。
[~SwitchB] stp root secondary
[*SwitchB] commit
配置端口的路径开销值,实现将该端口阻塞。
# 配置SwitchA的端口路径开销的计算方法为华为私有计算方法。
[~SwitchA] stp pathcost-standard legacy
[*SwitchA] commit
# 配置SwitchB的端口路径开销的计算方法为华为的私有计算方法。
[~SwitchB] stp pathcost-standard legacy
[*SwitchB] commit
# 配置SwitchC端口10GE1/0/1端口路径开销值为20000。
[~SwitchC] stp pathcost-standard legacy
[*SwitchC] interface 10ge 1/0/1
[*SwitchC-10GE1/0/1] stp cost 20000
[*SwitchC-10GE1/0/1] commit
[~SwitchC-10GE1/0/1] quit
# 配置SwitchD的端口路径开销的计算方法为华为的私有计算方法。
[~SwitchD] stp pathcost-standard legacy
[*SwitchD] commit
使能STP,实现破除环路。
将与Server相连的端口去使能STP
# 配置SwitchB端口10GE1/0/2的STP去使能。
[~SwitchB]interface10ge1/0/2
[~SwitchB-10GE1/0/2]stp disable
[*SwitchB-10GE1/0/2]commit
[~SwitchB-10GE1/0/2]quit
# 配置SwitchC端口10GE1/0/2的STP去使能。
[~SwitchC]interface10ge1/0/2
[~SwitchC-10GE1/0/2]stp disable
[*SwitchC-10GE1/0/2]commit
[~SwitchC-10GE1/0/2]quit
•设备全局使能STP。
[~SwitchA] stp enable
[*SwitchA] commit
[~SwitchB] stp enable
[*SwitchB] commit
[~SwitchC] stp enable
[*SwitchC] commit
[~SwitchD] stp enable
[*SwitchD] commit
######RSTP#######
配置思路
采用以下思路配置RSTP功能:
配置环网中的设备生成树协议工作在RSTP模式。
配置根桥和备份根桥设备。
配置端口的路径开销值,实现将该端口阻塞。
使能RSTP,实现破除环路。
操作步骤
配置环网中的设备生成树协议工作在RSTP模式。SwitchB、SwitchC和SwitchD的配置与SwitchA差不多
[~HUAWEI]system-view
[~HUAWEI]sysnameSwitchA
[*HUAWEI]commit
[~SwitchA]stp mode rstp
[*SwitchA]commit
配置根桥和备份根桥。
# 配置SwitchA为根桥。
[~SwitchA]stp root primary
[*SwitchA]commit
# 配置SwitchB为备份根桥。
[~SwitchB]stp root secondary
[*SwitchB]commit
配置端口的路径开销值,实现将该端口阻塞
# 配置SwitchA的端口路径开销的计算方法为华为私有计算方法。
[~SwitchA]stp pathcost-standard legacy
[*SwitchA]commit
# 配置SwitchB的端口路径开销的计算方法为华为的私有计算方法。
[~SwitchB]stp pathcost-standard legacy
[*SwitchB]commit
# 配置SwitchC端口10GE1/0/1端口路径开销值为20000。
[~SwitchC]stp pathcost-standard legacy
[*SwitchC]interface10ge1/0/1
[*SwitchC-10GE1/0/1]stp cost 20000
[*SwitchC-10GE1/0/1]commit
[~SwitchC-10GE1/0/1]quit
# 配置SwitchD的端口路径开销的计算方法为华为的私有计算方法。
[~SwitchD]stp pathcost-standard legacy
[*SwitchD]commit
使能RSTP,实现破除环路。
将与Server相连的端口去使能RSTP
# 配置SwitchB端口10GE1/0/2的RSTP去使能
[~SwitchB]interface10ge1/0/2
[~SwitchB-10GE1/0/2]stp disable
[*SwitchB-10GE1/0/2]commit
[~SwitchB-10GE1/0/2]quit
# 配置SwitchC端口10GE1/0/2的RSTP去使能。
[~SwitchC]interface10ge1/0/2
[~SwitchC-10GE1/0/2]stp disable
[*SwitchC-10GE1/0/2]commit
[~SwitchC-10GE1/0/2]quit
设备全局使能RSTP。
[~SwitchA]stp enable
[*SwitchA]commit
[~SwitchB]stp enable
[*SwitchB]commit
[~SwitchC]stp enable
[*SwitchC]commit
[~SwitchD]stp enable
[*SwitchD]commit
配置保护功能,如在根桥设备的指定端口配置根保护功能。
# 在SwitchA端口10GE1/0/1和10GE1/0/2上配置根保护功能。
[~SwitchA]interface10ge1/0/1
[~SwitchA-10GE1/0/1]stp root-protection
[*SwitchA-10GE1/0/1]quit
[*SwitchA]interface10ge1/0/2
[*SwitchA-10GE1/0/2]stp root-protection
[*SwitchA-10GE1/0/2]quit
[*SwitchA]commit
##### OSPF 配置示例 ######
配置OSPF基本功能:
# 配置SwitchA。
[~HUAWEI] system-view
[~HUAWEI] sysname SwitchA
[*HUAWEI] commit
[~SwitchA] router id 10.1.1.1
[*SwitchA] ospf 1
[*SwitchA-ospf-1] area 0
[*SwitchA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
[*SwitchA-ospf-1-area-0.0.0.0] quit
[*SwitchA-ospf-1] area 1
[*SwitchA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
[*SwitchA-ospf-1-area-0.0.0.1] quit
[*SwitchA-ospf-1] commit
[~SwitchA-ospf-1] quit
# 配置SwitchB。
[~HUAWEI] system-view
[~HUAWEI] sysname SwitchB
[*HUAWEI] commit
[~SwitchB] router id 10.2.2.2
[*SwitchB]ospf 1
[*SwitchB-ospf-1] area 0
[*SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
[*SwitchB-ospf-1-area-0.0.0.0]quit
[*SwitchB-ospf-1] area 2
[*SwitchB-ospf-1-area-0.0.0.2] network 192.168.2.0 0.0.0.255
[*SwitchB-ospf-1-area-0.0.0.2] quit
[*SwitchB-ospf-1] commit
[~SwitchB-ospf-1] quit
# 配置SwitchC。
[~HUAWEI]system-view
[~HUAWEI] sysname SwitchC
[*HUAWEI] commit
[~SwitchC] router id 10.3.3.3
[*SwitchC] ospf 1
[*SwitchC-ospf-1] area 1
[*SwitchC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
[*SwitchC-ospf-1-area-0.0.0.1] network 172.16.1.0 0.0.0.255
[*SwitchC-ospf-1-area-0.0.0.1] commit
[~SwitchC-ospf-1-area-0.0.0.1] quit
[~SwitchC-ospf-1] quit
# 配置SwitchD。
[~HUAWEI]system-view
[~HUAWEI] sysname SwitchD
[*HUAWEI] commit
[~SwitchD] router id 10.4.4.4
[*SwitchD] ospf 1
[*SwitchD-ospf-1] area 2
[*SwitchD-ospf-1-area-0.0.0.2] network 192.168.2.0 0.0.0.255
[*SwitchD-ospf-1-area-0.0.0.2] network 172.17.1.0 0.0.0.255
[*SwitchD-ospf-1-area-0.0.0.2] commit
[~SwitchD-ospf-1-area-0.0.0.2] quit
[~SwitchD-ospf-1] quit
# 配置SwitchE。
[~HUAWEI] system-view
[~HUAWEI] sysname SwitchE
[*HUAWEI] commit
[~SwitchE] router id 10.5.5.5
[*SwitchE] ospf 1
[*SwitchE-ospf-1] area 1
[*SwitchE-ospf-1-area-0.0.0.1] network 172.16.1.0 0.0.0.255
[*SwitchE-ospf-1-area-0.0.0.1] commit
[~SwitchE-ospf-1-area-0.0.0.1] quit
[~SwitchE-ospf-1] quit
# 配置SwitchF。
[~HUAWEI] system-view
[~HUAWEI] sysname SwitchF
[*HUAWEI] commit
[~SwitchF] router id 10.6.6.6
[*SwitchF] ospf 1
[*SwitchF-ospf-1] area 2
[*SwitchF-ospf-1-area-0.0.0.2] network 172.17.1.0 0.0.0.255
[*SwitchF-ospf-1-area-0.0.0.2] commit
[~SwitchF-ospf-1-area-0.0.0.2] quit
[~SwitchF-ospf-1] quit
++++++++++