poj3259-Wormholes

题目传送:poj3259
注意:本题起点为1,spfa做法:一共n个节点,每个节点进入队列的次数至多为n-1次,若进入大于等于n次,说明图中存在负权回路,满足“and return to the starting field a time before his initial departure”的条件,田里道路双向,虫洞单向且为负边。

题目描述:
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N
(1\leN\le500)fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output
NO
YES

Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

SPFA:

//#include<bits/stdc++.h>
#include<cstring>
#include<cstdio>
#include<queue>
//#include<iostream>
using namespace std;
const int maxn=1e4;
const int inf=1e9;
int e[maxn][maxn];
//int dis[maxn];
bool spfa(int start,int N){
    int book[maxn],sum[maxn],dis[maxn];
    memset(book,0,sizeof(book));
    memset(sum,0,sizeof(sum));
    for(int i=1;i<=N;i++)
        dis[i]=inf;
    dis[start]=0;
    queue<int>q;
    //q.clear();//C++中的queue自身不支持clear操作,双端队列deque支持clear操作
    while(!q.empty())q.pop();
    q.push(start);
    book[start]=1;//注意不是book[1]=1;
    ++sum[start];
    while(!q.empty()){
        int x=q.front();
        q.pop();
        book[x]=0;
        for(int i=1;i<=N;i++){
            //if(sum[i]>N)return true;
            if(e[x][i]<inf&&dis[i]>dis[x]+e[x][i]){//e[x][i]<inf条件不要忘记加,用邻接矩阵存图时,有边才能松弛
                dis[i]=dis[x]+e[x][i];
                if(!book[i]){
                    book[i]=1;
                    q.push(i);
                    ++sum[i];
                    if(sum[i]>=N)return true;//是否加=?
                }
            }
        }
    }
    return false;
}
int main(){
    int F,N,M,W,S,E,T;
    int st;
    scanf("%d",&F);
    for(int k=1;k<=F;k++){
        scanf("%d%d%d",&N,&M,&W);
        for(int i=1;i<=N;i++){//二维e数组初始化
            for(int j=1;j<=N;j++){
                if(i==j)e[i][j]=0;
                else e[i][j]=inf;
            }
        }
        for(int i=1;i<=M;i++){//田地里的路,无说明,注意双向,读入正边
            scanf("%d%d%d",&S,&E,&T);//有重复边?暂假设没有
            if(e[S][E]>T)
                e[S][E]=e[E][S]=T;
            if(i==1)st=S;
        }
        for(int i=1;i<=W;i++){//读入负边
            scanf("%d%d%d",&S,&E,&T);
            e[S][E]=-T;
            //e[S][E]=e[E][S]=-T;//虫洞的负边是单向的
        }
        //cout<<M<<endl;
        if(spfa(st,N))printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
    

做完这道题有几点醒悟:一开始时候总是纠结于题目没说明起点,该定哪个点为起点呢,上面的代码想了一天从wa到ac,后来终于发现由于习惯性思维把1当做起点,把book[start]=1;写成了book[1]=1; 不过也正是这个错误让我突然明白这道题和起点是哪个点一点关系也没有,只要图是联通的,可以设置任何点为起点,计算其他点到这个规定的起点的距离来判断这个图是否存在负环。而我则很蠢的把第一个输入的点作为起点来松弛。所以就一句话,判断有没有负环就完事了,如果图是联通的管他谁是起点。

vector写法:
spfa:

#include<iostream>
#include<vector>
#include<queue>
const int INF=1e9;
const int maxn=1e3+10;
using namespace std;
struct edge{
    int v;
    int w;
}edges[maxn*10];
vector<edge>v[maxn];//v可以看出一个二维数组
bool book[maxn];
int dis[maxn];
int sum[maxn];
int n,m,w,cnt;
void readedge(int e,int s,int t){//读入边
    cnt++;
    edges[cnt].v=s;
    edges[cnt].w=t;
    v[e].push_back(edges[cnt]);//v数组下标是起点,该数组记录了每个起点的所有边,v[e].size()就是以e为起点的所有出边的数量
}
bool spfa(){
    queue<int>q;
    book[1]=1;
    dis[1]=0;
    sum[1]=1;
    for(int i=2;i<=n;i++){
        book[i]=0;
        dis[i]=INF;
        sum[i]=0;
    }
    q.push(1);
    while(!q.empty()){
        int x=q.front();
        q.pop();
        book[x]=0;
        for(int i=0;i<v[x].size();i++){
            if(dis[v[x][i].v]>dis[x]+v[x][i].w){
                dis[v[x][i].v]=dis[x]+v[x][i].w;
                if(!book[v[x][i].v]){                   
                    book[v[x][i].v]=1;
                    sum[v[x][i].v]++;
                    if(sum[v[x][i].v]>=n)//某点入队的次数大于等于n,该图必然存在负环
                        return true;
                    q.push(v[x][i].v);//把能松弛且不在队列的点入队
                }
            }
        }
    }
    return false;
}
int main(){
    int f;
    cin>>f;
    for(int k=1;k<=f;k++){
        cin>>n>>m>>w;
        cnt=0;
        for(int i=1;i<=n;i++)
            v[i].clear();
        for(int i=0;i<m;i++){//读入边
            int s,e,t;
            cin>>s>>e>>t;
            readedge(s,e,t);
            readedge(e,s,t);//道路为双向,所以要反向读入一次
        }
        for(int i=0;i<w;i++){
            int s,e,t;
            cin>>s>>e>>t;
            readedge(s,e,-t);//虫洞数据是单向的负边
        }
        if(spfa())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 214,377评论 6 496
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,390评论 3 389
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 159,967评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,344评论 1 288
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,441评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,492评论 1 292
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,497评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,274评论 0 269
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,732评论 1 307
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,008评论 2 328
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,184评论 1 342
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,837评论 4 337
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,520评论 3 322
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,156评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,407评论 1 268
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,056评论 2 365
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,074评论 2 352

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,319评论 0 10
  • The Inner Game of Tennis W Timothy Gallwey Jonathan Cape ...
    网事_79a3阅读 12,000评论 3 20
  • 长长的铁轨,呜呜的轰鸣声,火车总是在眼前呼啸而过,没有片刻的停留,最美的是沿途的风景,最好的是火车上的偶遇。 狭小...
    玄白不白阅读 347评论 0 1
  • 你胸口的痣 是远方的一座孤岛 而我顺着孤单的方向 渴望你一望无际的海
    每日一湿阅读 249评论 0 0
  • 【月回顾模板】 一、一月整体分析 (主要分析说明一月份的三个核心目标的完成情况) 二、各领域情况分析 (主要分析自...
    盛某阅读 184评论 0 0