PAT 甲级 刷题日记|A 1090 Highest Price in Supply Chain (25 分)

单词积累

increment 增量 增加

题目

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. S root for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6结尾无空行

Sample Output:

1.85 2结尾无空行

思路

这是一个由零售商、经销商与供应商构成的一般树。需要找到最大深度,以及该深度存在的叶节点数。

自己一开始对一般树的掌握不很好,想到了用类似并查集的方法去做,这个缺点是每次都是从叶节点处开始查找,如果出现下图所示的极端情况时,时间复杂的是O(n 方),最后一个样例超时。


1628586481263.png

参考的做法是,用向量存储孩子,这棵树就可以表示为数组向量。数组中的第i个元素,就是以i为父节点的所有节点构成的向量。最大深度只需从根节点处开始遍历。

代码1

#include <bits/stdc++.h>
using namespace std;

const int maxn = 100001;
int num[maxn];
int father[maxn];
int height[maxn];
int N;
double P, r;

void inital() {
    for (int i = 0; i < N; i++) {
        father[i] = i;
        height[i] = 0;
    }
}

int findfather(int x) {
    int times = 0;
    while (father[x] != -1) {
        x = father[x];
        times++;
    }
    return times;
}

void Union(int a, int b) {
    father[a] = b;
    if (b != -1) height[b] = 1;
}


int main() {
    cin>>N>>P>>r;
    inital();
    for (int i = 0; i < N; i++) {
        scanf("%d", &num[i]);
        Union(i, num[i]);
    }
    int res = 0;
    int clu = 0;
    for (int i = 0; i < N; i++) {
        if(height[i] == 0) {
            if(findfather(i) == res) clu++;
            else if(findfather(i) > res) {
                res = findfather(i);
                clu = 1;
            }
        }
    }
    double price = P * pow(1 + r * 0.01, res);
    printf("%.2f %d", price, clu);
    
} 

代码2(BFS)

#include <bits/stdc++.h>
using namespace std;

const int maxn = 100001;
vector<int> num[maxn];
int N;
double P, r;
int maxdepth = 0;
int clus = 0;


void BFS(int root, int depth) {
    if (num[root].size() == 0) {
        
        if (depth == maxdepth) {
            clus++;
        } else if (depth > maxdepth) {
            clus = 1;
            maxdepth = depth;
        }
        return;
    }
    
    for (int i = 0; i <num[root].size(); i++) {
        BFS(num[root][i], depth + 1);
    }
}

int main() {
    cin>>N>>P>>r;
    int root = -1;
    int temp;
    for (int i  = 0; i < N; i++) {
        cin>>temp;
        if (temp == -1) root = i;
        else {
            num[temp].push_back(i);
        }
    }
    if (root != -1) BFS(root, 0);
    double price = P * pow(1 + r * 0.01, maxdepth);
    printf("%.2f %d", price, clus);
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 216,402评论 6 499
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,377评论 3 392
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 162,483评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,165评论 1 292
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,176评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,146评论 1 297
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,032评论 3 417
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,896评论 0 274
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,311评论 1 310
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,536评论 2 332
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,696评论 1 348
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,413评论 5 343
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,008评论 3 325
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,659评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,815评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,698评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,592评论 2 353

推荐阅读更多精彩内容