1063 Set Similarity (25 分)
Given two sets of integers, the similarity of the sets is defined to be Nc/Nt ×100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.
Input Specification:
Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104 ) and followed by M integers in the range [0,109 ]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
Output Specification:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%
题目大意:
本题定义集合相似度Nc/Nt*100%,其中Nc是两个集合中共有的不相等元素个数,Nt是两个集合中不相等元素的个数。你的任务是计算给定的集合的相似度。
#include <iostream>
#include <vector>
#include <set>
using namespace std;
int main(){
int n;
cin>>n;
vector<set<int> > v(n);
for(int i=0;i<n;i++){
int m;
cin>>m;
while(m--){
int val;
cin>>val;
v[i].insert(val);
}
}
int k;
cin>>k;
for(int i=0;i<k;i++){
int a,b;
cin>>a>>b;
a--,b--;
int cnt=0;
for(auto it:v[a]){
if(v[b].find(it)!=v[b].end()) cnt++;
}
printf("%.1lf%\n",cnt*100.0/(v[a].size()+v[b].size()-cnt));
}
return 0;
}