Poj 3211 Washing Clothes

题目

Poj 3211 Washing Clothes

Description
Dearboy was so busy recently that now he has piles of clothes to wash. Luckily, he has a beautiful and hard-working girlfriend to help him. The clothes are in varieties of colors but each piece of them can be seen as of only one color. In order to prevent the clothes from getting dyed in mixed colors, Dearboy and his girlfriend have to finish washing all clothes of one color before going on to those of another color.

From experience Dearboy knows how long each piece of clothes takes one person to wash. Each piece will be washed by either Dearboy or his girlfriend but not both of them. The couple can wash two pieces simultaneously. What is the shortest possible time they need to finish the job?

Input
The input contains several test cases. Each test case begins with a line of two positive integers M and N (M < 10, N < 100), which are the numbers of colors and of clothes. The next line contains M strings which are not longer than 10 characters and do not contain spaces, which the names of the colors. Then follow N lines describing the clothes. Each of these lines contains the time to wash some piece of the clothes (less than 1,000) and its color. Two zeroes follow the last test case.

Output
For each test case output on a separate line the time the couple needs for washing.


Sample Input
3 4
red blue yellow
2 red
3 blue
4 blue
6 red
0 0

Sample Output
10

大意就是题目的主人公与其女票一起洗衣服,两个人可以一起洗(双线程),但是衣服有很多种颜色,为了不让衣服色混,所以俩人必须要同时洗一种颜色的衣服,如果有一个人还没有洗完,另一个人就只能等待,直到俩人都洗完,才能洗下一个颜色的衣服,计算最小的耗时。

解题思路

  1. 因为颜色不能混,所以其实也就是不同颜色之间的衣服互不干扰,计算每种颜色的耗时,累加得到计算结果。
  2. 计算每种颜色的时候,可以转化为背包问题。因为是双线程,如果单人总耗时为 total 的话,两个人中肯定有一个的耗时是 >= total/2 的,所以可以理解为容量为 total/2 的背包,计算背包的最大重量,然后 “total - 最大重量” 就是单色的耗时了。

代码

#include <stdio.h>
#include <iostream>
#include <bitset>
#include <cstring>
#include <algorithm>

using namespace std;

char colorList[10][15];
int getColorIndex(int colorNum, char* color) {
    for (int i = 0; i < colorNum; i++) {
        bool isEqual = true;
        for (int t = 0; t < 15; t++) {
            if (color[t] != colorList[i][t]) {
                isEqual = false;
                break;
            } else if (color[t] == '\0') {
                break;
            }
        }
        if (isEqual) {
            return i;
        }
    }
    return 0;
}

struct ClothePile {
    int time;
    int index;
};
ClothePile clothePile[1005];

bool compare(ClothePile a,ClothePile b) {
    if (a.index != b.index) {
        return a.index < b.index;
    } else {
        return a.time < b.time;
    }
}

// 计算每种颜色所耗费的时间,[start, end),左闭右开,代表一个颜色衣服在 clothePile 中的索引
int calculateOneColor(int start, int end, int pileNum) {
    int total = 0;
    for (int i = start; i < end; i++) {
        total += clothePile[i].time;
    }
    int maxTime = total / 2;
    
    bitset<100005> resultBitSet(0);
    
    for (int i = start; i < end; i++) {
        resultBitSet |= (resultBitSet << clothePile[i].time);
        resultBitSet.set(clothePile[i].time);
    }
        
    int result = 0;
    for (int i = maxTime; i >= 1; i--) {
        if (resultBitSet.test(i)) {
            result = i;
            break;
        }
    }
    return total - result;
}

// 给定 clothePile (有序),然后计算每种颜色衣服耗费的时间,累加得到结果并返回
int calculateResult(int pileNum) {
    
    // 排序
    sort(clothePile, clothePile + pileNum, compare);
    
    int start = 0, end = 0;
    int total = 0;
    for (int i = 1; i <= pileNum; i++) {
        if (i == pileNum || clothePile[i].index != clothePile[i - 1].index) {
            end = i;
            total += calculateOneColor(start, end, pileNum);
            start = i;
        }
    }
    return total;
}

// 处理输入、格式化数据、计算、输出
bool processInput() {
    
    // 输入
    int colorNum, pileNum;
    scanf("%d %d", &colorNum, &pileNum);
    if (colorNum == 0 && pileNum == 0) {
        return false;
    }
    
    for (int i = 0; i < colorNum; i++) {
        scanf("%s", colorList[i]);
    }
    
    int time;
    char closeColor[15] = {0};
    for(int i = 0; i < pileNum; i++) {
        scanf("%d %s", &time, closeColor);
        // 格式化数据,因为 string 比较难处理,所以这里把字符串映射到 colorList 的 index 上
        clothePile[i].index = getColorIndex(colorNum, closeColor);
        clothePile[i].time = time;
    }
    
    // 计算并输出
    printf("%d\n", calculateResult(pileNum));
    return true;
}

int main(int argc, const char * argv[]) {
    while (processInput());
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 213,928评论 6 493
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,192评论 3 387
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 159,468评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,186评论 1 286
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,295评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,374评论 1 292
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,403评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,186评论 0 269
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,610评论 1 306
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,906评论 2 328
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,075评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,755评论 4 337
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,393评论 3 320
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,079评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,313评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,934评论 2 365
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,963评论 2 351

推荐阅读更多精彩内容