一、/*约数个数
输入一个正整数N (1
样例输入
12
样例输出
6
样例说明
12的约数包括:1,2,3,4,6,12。共6个
*/
#include<stdio.h>
int main(){
int n,cnt=0,i;
scanf("%d",&n);
for(i=1;i<=n;i++){
if(n%i==0){
cnt++;
}
}
printf("%d",cnt);
return 0;
}
二、/*字符大小写转换问题描述 编写一个程序,输入一个字符串(长度不超过20),然后把这个字符串内的每一个字符进行大小写变换,即将大写字母变成小写,小写字母变成大写,然后把这个新的字符串输出。
输入格式:输入一个字符串,而且这个字符串当中只包含英文字母,不包含其他类型的字符,也没有空格。
输出格式:输出经过转换后的字符串。
输入输出样
例样例输入
AeDb
样例输出
aEdB*/
#include<stdio.h>
#include<string.h>
int main(){
char a[30];
while(scanf("%s", a)!=EOF){
int n = strlen(a);
for(int i = 0; i < n; i++){
if('A'<=a[i] && a[i]<='Z'){
a[i]+=32;
continue;
}
if('a'<=a[i] && a[i]<='z')
a[i]-=32;
}
printf("%s\n", a);
}
return 0;
}
三、/*字串 问题描述对于长度为5位的一个01串,每一位都可能是0或1,一共有32种可能。它们的前几个是:0000000001000100001100100请按从小到大的顺序输出这32种01串。
输入格式 本试题没有输入。
输出格式输出32行,按从小到大的顺序每行一个长度为5的01串。
样例输出
00000
00001
00010
00011
<以下部分省略>*/
#include<stdio.h>
int main(){
int a,b,c,d,e;
for(a=0;a<2;++a)
for(b=0;b<2;++b) for(c=0;c<2;++c) for(d=0;d<2;++d) for(e=0;e<2;++e) printf("%d%d%d%d%d\n",a,b,c,d,e);
return 0;
}