1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c
​1
​​ , c
​2
​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C2​​ .

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

code

#include <iostream>
#include <algorithm>

using namespace std;

int main()
{
    int dis[500],num[500],weight[500],w[500];
    int adj[500][500];
    int visit[500];
    const int inf = 999999;
    int n,m,origin,dest;
    scanf("%d%d%d%d",&n,&m,&origin,&dest);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&weight[i]);
    }
    fill(adj[0],adj[0]+500*500,inf);
    fill(dis,dis+500,inf);
    fill(num,num+500,0);
    int a,b,c;
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        adj[a][b] = adj[b][a] = c;
    }
    dis[origin] = 0;
    w[origin] = weight[origin];
    num[origin] = 1;
    for(int i=0;i<n;i++)
    {
        int x=-1, minn=inf;
        for(int j=0;j<n;j++)
        {
            if(!visit[j] && dis[j]<minn) {
                minn = dis[j];
                x = j;
            }
        }
        visit[x] = 1;
        for(int y=0;y<n;y++)
        {
            if(dis[y]>dis[x]+adj[x][y]) {
                dis[y] = dis[x] + adj[x][y];
                num[y] = num[x];
                w[y] = weight[y]+w[x];
            }else if(dis[y] == dis[x]+adj[x][y] && dis[x]!=0) {
                num[y] = num[y] + num[x];
                if(w[x]+weight[y]>w[y]) {
                    w[y] = w[x] + weight[y];
                }
            }
        }
//        printf("%d\n",i);
//        printf("num:");
//        for(int k=0;k<n;k++)  printf("%d ",num[k]);
//        printf("\n");
//        printf("dis:");
//        for(int k=0;k<n;k++)  printf("%d ",dis[k]);
//        printf("\n");
//        printf("w:");
//        for(int k=0;k<n;k++)  printf("%d ",w[k]);
//        printf("\n");
    }
//    for(int i=0;i<n;i++)
//    {
//        for(int j=0;j<n;j++)
//        {
//            printf("%d ",adj[i][j]);
//        }
//        printf("\n");
//    }
    printf("%d %d", num[dest],w[dest]);
    return 0;
}

note

  • Dijkstra 算法
    假设我们要求从A到F的最短路个数和最短路上最大的点权和
example

上图的邻接矩阵表示:
adj[6][6] = \left[ \begin{matrix} InF & 1 & 2 &3& 4& InF\\ 1 &InF& InF& InF& InF& 3\\ 2 &InF &InF &1 &InF& 2\\ 3 &InF& 1 &InF &InF&1\\ 4 &InF& InF& InF &InF&1\\ InF &3& 2 &1& 1 &InF \end{matrix}\right]

点权数组
weight[6] =\left[\begin{matrix} 1 & 2&3&4& 5&6\end{matrix}\right]

每次迭代找到dis数组中最小值,并对与该节点相连的边进行松弛

A B C D E F
w 1 0 0 0 0 0
dis 0 inf inf inf inf inf
num 1 0 0 0 0 0
visit 0 0 0 0 0 0
A B C D E F
w 1 3 4 5 6 0
dis 0 1 2 3 4 inf
num 1 1 1 1 1 0
visit 1 0 0 0 0 0
A B C D E F
w 1 3 4 5 6 9
dis 0 1 2 3 4 4
num 1 1 1 1 1 1
visit 1 1 0 0 0 0
A B C D E F
w 1 3 4 8 6 10
dis 0 1 2 3 4 4
num 1 1 1 2 1 2
visit 1 1 1 0 0 0
A B C D E F
w 1 3 4 8 6 14
dis 0 1 2 3 4 4
num 1 1 1 2 1 4
visit 1 1 1 1 0 0
A B C D E F
w 1 3 4 8 6 14
dis 0 1 2 3 4 4
num 1 1 1 2 1 4
visit 1 1 1 1 1 0
A B C D E F
w 1 3 4 8 6 14
dis 0 1 2 3 4 4
num 1 1 1 2 1 4
visit 1 1 1 1 1 1
  • fill 和 memset
    fill 可以填充任何值,包含在<algorithm>
    对vector:fill(v.begin(), v.end(), -1)
    对一维数组:fill(arr, arr + 10, 2)
    对二维数组:fill(adj[0],adj[0]+500*500,inf);
    memset按照字节进行填充,一般用来填充char型数组,也经常用于填充int型的全0或全-1操作,包含在<cstring>
    对数组:memset(a, 0, sizeof(a))
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 212,185评论 6 493
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 90,445评论 3 385
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 157,684评论 0 348
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 56,564评论 1 284
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 65,681评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 49,874评论 1 290
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,025评论 3 408
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,761评论 0 268
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,217评论 1 303
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,545评论 2 327
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,694评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,351评论 4 332
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,988评论 3 315
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,778评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,007评论 1 266
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,427评论 2 360
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,580评论 2 349

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,312评论 0 10
  • 不管你在中国的哪一个城市,只要你还准备结婚,还有个工作,而且父母安在,那你或许想过这件事情:在这个城市里,我是不是...
    旗襄阅读 201评论 0 0
  • 大二刚要结尾,就要面临人生的选择。到底是选择考研还是直接工作。我也只是二十岁而已,就要自己去做这样的选择,真的好...
    小焕仔阅读 500评论 12 1
  • 等待一个住在心里的人,当耐心疏漏在消逝的时间之后,不安的黑精灵,在每一条神经上跳跃,它可知道它的快乐建立在承受...
    21岁的大女孩阅读 147评论 0 0
  • 还是没能憋住,在房东的一句句扎心的话语下,今天终于还是哭了出来。 搬家了,跟着房东一起搬的。 什么都变遭了,本以为...
    小佛系的彩老师阅读 233评论 2 0