1002 A+B for Polynomials (25)
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
思路:模拟。注意,系数为0时不输出,所以 -1 + 1这种情况不能输出!
#include <bits/stdc++.h>
using namespace std;
int main()
{
double p1[1010] = {0};
double e2[1010] = {0};
double c2[1010] = {0};
int k, e, i, cnt = 0, t = 2;
double c;
while(t--){
cin >> k;
for(i = 0; i < k; i++){
cin >> e >> c;
p1[e] += c;
}
}
for(i = 0; i < 1010; i++)
if(p1[i] != 0.0){
e2[cnt] = i;
c2[cnt++] = p1[i];
}
cout << cnt;
if(cnt != 0)
cout << " ";
for(i = cnt - 1; i >= 0; i--){
printf("%.0f %.1f", e2[i], c2[i]);
if(i != 0)
cout << " ";
}
return 0;
}