Sum Problem
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 570855 Accepted Submission(s): 144823
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
Author
DOOM III
Recommend
We have carefully selected several similar problems for you: 1002 1090 1003 1091 1004
代码:
#include"stdio.h"
int main()
{
int n, sum = 0;
while(scanf("%d",&n)==1)
{
sum = 0;
for(int i = 1; i <= n; i++)
{
sum += i;
}
printf("%d\n\n",sum);
}
}
注意点
include"stdio.h"
-
printf
没有& - 要求答案后空一行需要两个
\n