001. mysql5.7.19版本在忘记密码情况下修改root密码

昨天,修改了一下mysql的root的密码,但是忘记了,今天启动项目时,项目无法启动,确定是连接不上数据库;
在网上找了好多在忘记密码的情况下修改root用户密码,但是都失败了,然后搜索了一下mysql5.7.19版本修改root用户密码,最后修改成功;
具体修改步骤如下:

  1. 在cmd窗口中,使用net stop mysql 停掉mysql服务;
  2. 在cmd窗口中,进入bin目录,执行mysqld --skip-grant-tables命令(如果没有反应,说明正常,如果没有任何输出结果,又回到bin目录的话,注销一下,重新执行以上步骤);
  3. 执行mysql 或mysql -uroot进入mysql;
  4. 修改密码:
    update mysql.user set authentication_string=password('新密码') where user='root';
    注: 网上好多修改root密码的列是password,而5.7.19版本没有该字段,将password列变为authentication_string列;
    查看mysql数据库中的user表可以发现,没有password列,但是有authentication_string列;
Paste_Image.png

刷新权限(必须步骤,否则修改后的密码无法生效): flush privileges;
启动mysql服务,使用新密码登录mysql;

最后编辑于 :
©著作权归作者所有,转载或内容合作请联系作者
【社区内容提示】社区部分内容疑似由AI辅助生成,浏览时请结合常识与多方信息审慎甄别。
平台声明:文章内容(如有图片或视频亦包括在内)由作者上传并发布,文章内容仅代表作者本人观点,简书系信息发布平台,仅提供信息存储服务。

相关阅读更多精彩内容

友情链接更多精彩内容