统计给定文本文件中汉字的个数。
Input
输入文件首先包含一个整数n,表示测试实例的个数,然后是n段文本。
Output
对于每一段文本,输出其中的汉字的个数,每个测试实例的输出占一行。
[Hint:]从汉字机内码的特点考虑~
Sample Input
2
WaHaHa! WaHaHa! 今年过节不说话要说只说普通话WaHaHa! WaHaHa!
马上就要期末考试了Are you ready?
Sample Output
14
9
程序说明:
汉字占两个字节,且为负数(机内码最高位是1)。
代码如下:
#include <iostream>
#include <string>
#include <cstring>
using namespace std;
int main() {
int n;
scanf("%d", &n);
getchar();
while(n--) {
string a;
int cnt = 0;
getline(cin, a);
for(int i = 0; i < a.length(); i++) {
if(a[i] < 0)
cnt++;
}
printf("%d\n", cnt / 2);
}
return 0;
}