2020-03-07

1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

      
    

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

      
    

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题意大概是输入两个数N,M(<=2000),接下来N行数据,每行第一列为学生ID,第二行为C成绩,第三行为M成绩,第四行为E成绩,(都为int),接下来输入M行学生ID,输出这些学生A(平均排名成绩,需自己算)>C>M>E(同排名重要性排行)中排名最高的排名以及科目,如果不存在这个学生ID则输出N/A。

#include<iostream>
using namespace std;
typedef struct student{
    string str;
    int c;
    int m;
    int e;
    int a;
}student;
int main(){
    void bestRank(string str,student arr[],int length);
    int m,n;
    student arr[2001];
    string str[2001];
    cin>>m>>n;
    int i=0,j=0;
    for(i;i<m;++i){
        cin>>arr[i].str>>arr[i].c>>arr[i].m>>arr[i].e;
        arr[i].a = (arr[i].c+arr[i].m+arr[i].e)/3;
    }
    for(j;j<n;j++){
        cin>>str[j];
    }
    for(int k=0;k<j;++k){
        bestRank(str[k],arr,i);
    }
    return 0;
}
//bestRank()查询输入学生id为str的在arr数组中rank最高的某项成绩。
void bestRank(string str,student arr[],int length){
    int index=-1;
    //找到当前字符在结构体中的位置 
    for(int i=0;i<length;++i){
        if(str==arr[i].str){
            index = i;
            break;
        }
    }
    if(index!=-1){
        int rank[4]={1,1,1,1};//默认排名为1 
        for(int i=0;i<length;++i){
            //存在比当前字符串平均成绩高的,排名下降一位 
            if(arr[i].a>arr[index].a&&i!=index){
                rank[0]++;
            }
            if(arr[i].c>arr[index].c&&i!=index){
                rank[1]++;
            }
            if(arr[i].m>arr[index].m&&i!=index){
                rank[2]++;
            }
            if(arr[i].e>arr[index].e&&i!=index){
                rank[3]++;
            }           
        } 
        //rank[0]代表A, rank[1]代表C,rank[2]代表M,rank[3]代表E
        int index=999999;
        int sign=-1;
        for(int i=0;i<4;i++){
            if(rank[i]<index){
                index = rank[i];
                sign = i;
            }
        }
        if(sign==0){
            printf("%d A\n",rank[0]);
        }   
        if(sign==1){
            printf("%d C\n",rank[1]);
        }
        if(sign==2){
            printf("%d M\n",rank[2]);
        }
        if(sign==3){
            printf("%d E\n",rank[3]);
        }
    }
    else{
        printf("N/A\n");
    }
} 
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,921评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 87,635评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 151,393评论 0 338
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,836评论 1 277
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,833评论 5 368
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,685评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,043评论 3 399
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,694评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 42,671评论 1 300
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,670评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,779评论 1 332
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,424评论 4 321
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,027评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,984评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,214评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,108评论 2 351
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,517评论 2 343

推荐阅读更多精彩内容