1051 Pop Sequence (25 分)(堆栈模拟)
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
题目大意
给定一个栈,1,2,...,n是入栈序列,元素出栈顺序随意,现给定出栈顺序(e.g.1~n的一个排列),问这个出栈顺序是否合理,合理输出"YES",否则输出"NO"。
分析
本题考查堆栈的模拟,现将出栈元素保存在数组v中,每入栈一个元素判断入栈后栈的容量是否超过m,若超过则设置yes=false,并且break。接着利用while将栈顶元素弹出,直到栈空或者出栈元素不等于栈顶元素,e.g.在下次压栈之前将本次可以出栈的元素全部出栈,同时将出栈元素索引向前推进。在最后一个元素压栈完毕后,接下来的操作便是将按照出栈顺序将栈内元素全部出栈。
若最后发现栈不空,则表明最后一步操作出现问题,即出栈顺序不合理。
#include <iostream>
#include <stack>
#include <vector>
using namespace std;
int main(){
int m,n,k;
cin>>m>>n>>k;
for(int i=0;i<k;i++){
vector<int> v(n);
bool yes=true;
for(int j=0;j<n;j++){
cin>>v[j];
}
stack<int> s;
int cur=0;
for(int j=1;j<=n;j++){
s.push(j);
if(s.size()>m){
yes=false;
break;
}
while(!s.empty() && s.top()==v[cur]){
s.pop();
cur++;
}
}
if(!s.empty()) yes=false;
printf("%s\n",yes?"YES":"NO" );
}
return 0;
}