1101 Quick Sort (排序)

1101 Quick Sort (25 分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?
For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​ ). Then the next line contains N distinct positive integers no larger than 10​9​ . The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

解题思路:

原思路:

本题涉及快速排序,题面的要求是统计并且找出给定序列中的主元(排序前元素的位置与排序后元素的位置一致),本题原始解题方法是遍历序列并记录访问元素左边的最大值,若左边的最大值小于访问元素,则将其收入set,再次逆序遍历序列并记录元素右边的最小值,若右边的最小值小于访问元素,则将访问元素从set中擦除(但是只通过了两个测试,大批量的测试点不能通过......,沉思了很长时间,发现若set中不存在该元素,怎么能擦除(erase)),然后加上erase前的find判断测试点全部通过.
注意:在erase之前一定要判断是否待erase的元素是否存在,在pop之前一定要判断队列堆栈中是否为空

博客思路浮现:

查看了柳婼的解题思路,发现有可取之处,先将将原序列存在两个数组中(设定数组a和数组b),对数组a进行排序,然后对数组b进行遍历,并且存下访问元素左边最大值max,若max的值小于访问元素,则将访问元素收入输出结果中,同层再更新max为访问元素左边(包括访问元素)最大值。

原解题思路代码:
#include <iostream>
#include <vector>
#include <set>
using namespace std;
vector<int> v;
int main(){
    int n;
    cin>>n;
    v.resize(n);
    set<int> ans;
    int maxnum=-1;
    int cnt=0;
    for(int i=0;i<n;i++){
        cin>>v[i];
        if(maxnum<v[i]) {
            maxnum=v[i];
            ans.insert(v[i]);
            cnt++;
        }
    }
    int minnum=1100000001;
    for(int i=n-1;i>=0;i--){
        if(minnum>v[i]){
            minnum=v[i];
        }else if(ans.find(v[i])!=ans.end()){
            ans.erase(v[i]);
            cnt--;
        }
    }
    cout<<cnt<<endl;
    bool isfirst=true;
    for(auto it:ans){
        if(isfirst){
            cout<<it;
            isfirst=false;
        }else cout<<" "<<it;
    }
    cout<<endl;
    
    return 0;
}
博客浮现代码:
#include <algorithm>
#include <iostream>
using namespace std;
int a[100000],b[100000];
int main(){
    int n;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>a[i];
        b[i]=a[i];
    }
    sort(a,a+n);
    int cnt=0,max=0;
    int ans[100000];
    for(int i=0;i<n;i++){
        if(a[i]==b[i] && max<b[i]) ans[cnt++]=a[i];
        if(max<b[i]) max=b[i];
    }
    printf("%d\n",cnt);
    for(int i=0;i<cnt;i++){
        if(i!=0) printf(" ");
        printf("%d",ans[i]); 
    }
    printf("\n");
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 219,366评论 6 508
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 93,521评论 3 395
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 165,689评论 0 356
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,925评论 1 295
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,942评论 6 392
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,727评论 1 305
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,447评论 3 420
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 39,349评论 0 276
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,820评论 1 317
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,990评论 3 337
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 40,127评论 1 351
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,812评论 5 346
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,471评论 3 331
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 32,017评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 33,142评论 1 272
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 48,388评论 3 373
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 45,066评论 2 355

推荐阅读更多精彩内容