1065 A+B and C (64bit) (20 分)
Given three integers A, B and C in [−263 ,263], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
分析
a,b,c,sum(=a+b)均定义为long long,范围为[-263,263-1],当a,b同号时相加可能存在溢出,当a,b均为正数时,a+b的范围是(0,264-2],溢出的范围是[263,264-2],在long long范围内表示为[2-63,-2],<font color="hotpink">所以溢出时,sum<0</font>,<font color="hotpink">263==2-63,264==0</font>,同理当a,b均为负数时,a+b的范围是[-264,0),在[-264,-2-63-1]范围内会溢出,这个范围在long long中表示为[0,263-1],<font color="hotpink">所以溢出时,sum>=0</font>,当sum没有溢出时,可以按照常规判断。
注:关于整形数的表示范围的推演可以参考博客[1]或者阅读计算机组成原理相关书籍
#include<iostream>
using namespace std;
int main(){
int t;
cin>>t;
for(int i=1;i<=t;i++){
long long a,b,c,sum;
cin>>a>>b>>c;
sum=a+b;
if(a>0 && b>0 && sum<0) printf("Case #%d: true\n",i);
else if(a<0 && b<0 && sum>=0) printf("Case #%d: false\n",i);
else printf("Case #%d: %s\n",i,sum>c?"true":"false");
}
}