zabbix proxy负载优化

最近几个月换了工作,接手了zabbix监控,每天做一点事情,心血来潮决定把过程记录下来。

对新的zabbix环境检查,发现proxy负载不太均衡,决定将负载平均地分配到proxy中,前后对比:

下面说一下过程:

    1、找到一个proxy下的所有主机,两种办法:一是通过zabbixapi调用;二是从proxy页面加工。   我采用方案二,Administration --> proxies ,选择一个proxy,查看源码,获取agent  list。

    2、利用ansible,找出list中可批量执行的list。将list分成30个1组,1st,2st,3st,4st....

    3、依次执行,下面的命令,完成zabbixconfig文件的修改,并重启agent

ansible -i zbx-p-p3.txt 6th -m shell -a 'sed -i "s/zbx_p.dev.zpidc.com/zbx_p3.dev.zpidc.com/g" /etc/zabbix/etc/zabbix_agentd.conf'

ansible -i zbx-p-p3.txt 6th -m shell -a 'cat /etc/zabbix/etc/zabbix_agentd.conf |egrep -v "^$|^#"'

ansible -i zbx-p-p3.txt 6th -m shell -a 'service zabbix_agentd restart'

    4、configuration,host,调整 Monitored by proxy 指向。这个地方注意,如果开启了自动注册功能,则需要一般将hostmetadata设置成自动注册的类型,这个"Monitored by proxy"会自动发生改变。否则不会。

    5、监控面板会报出一些agent 10分钟收不到agent数据的错误,总结一下几个情况:

        1、页面主机名称与conf文件不一致

        2、页面的proxy名称和conf文件不一致

        3、agent重启失败(一般是因为agent.pid写目录没权限导致)

        4、网络不通,新proxy无法telnet通agent的10050端口

总的来说,这是zabbix年久失修,标准化不彻底,数据增加缺少规划综合导致的工作。

对比一下结果:

优化前:

前

后:

最后编辑于 :
©著作权归作者所有,转载或内容合作请联系作者
【社区内容提示】社区部分内容疑似由AI辅助生成,浏览时请结合常识与多方信息审慎甄别。
平台声明:文章内容(如有图片或视频亦包括在内)由作者上传并发布,文章内容仅代表作者本人观点,简书系信息发布平台,仅提供信息存储服务。

相关阅读更多精彩内容

  • 目前我的playbook只允许centos或redhat 6系列系统来安装zabbix客户端,并且客户端的版本是2...
    SkTj阅读 1,712评论 0赞 3
  • Zabbix简介 Zabbix官方网站Zabbix中文文档 本文系统环境是CentOS7x86_64, Zabbi...
    Zhang21阅读 8,458评论 0赞 37
  • 1.写在前面 本文主要介绍的是zabbix的编译安装过程,包含它的基础环境LNMP,虽然zabbix官方一般推荐的...
    天之蓝色阅读 2,723评论 0赞 16
  • 每个星期末的下午, 最好阳光正好或者下点小雨。 拿着两把纯色的伞, 坐着不同班次的公交车, 穿梭在或繁华或安静的大...
    极恶小丑阅读 188评论 0赞 1
  • 今日体验:今天换迈腾的门拉手支架,都装完后,试上下升降玻璃,发现玻璃膜上有蹭的印子,以为是里面没装好,但是检查发现...
    bbaf70c1705c阅读 166评论 0赞 0

友情链接更多精彩内容