1130 - Host '172.18.0.1' is not allowed to connect to this MySQL server

  • 使用docker-compose拉起的mysql:
shop_db:
    restart: always
    image: mysql/mysql-server
    container_name: mysql_server
    ports:
      - 3307:3306   # 使用3307是因为防止本机默认启动mysql而抛出端口占用错误
    environment:
      TZ: Asia/Shanghai
      MYSQL_ROOT_PASSWORD: "password"   # defaultUser : root
      MYSQL_DATABASE: "goweb"
    command:
      --character-set-server=utf8mb4
      --collation-server=utf8mb4_general_ci
      --explicit_defaults_for_timestamp=true
      --lower_case_table_names=1
      --max_allowed_packet=128M
      # --skip-name-resolve
      # --sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION,NO_ZERO_DATE,NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO"
    volumes:
      - ./docker-db:/var/lib/mysql
  • 本来用的是mysql57,但是由于设备更换为M1芯片,不能启动mysql57,最终只能升级mysql,就出现了不可链接的错误;

  • 解决:

    • 通过docker进入容器,mysql -uroot -p password(用户名跟密码,看我上面的配置)
    • use mysql
    • update mysql.user set 'host' = '%' where User = 'root';
    • flush privileges;
©著作权归作者所有,转载或内容合作请联系作者
【社区内容提示】社区部分内容疑似由AI辅助生成,浏览时请结合常识与多方信息审慎甄别。
平台声明:文章内容(如有图片或视频亦包括在内)由作者上传并发布,文章内容仅代表作者本人观点,简书系信息发布平台,仅提供信息存储服务。

相关阅读更多精彩内容

友情链接更多精彩内容