- 使用
docker-compose拉起的mysql:
shop_db:
restart: always
image: mysql/mysql-server
container_name: mysql_server
ports:
- 3307:3306 # 使用3307是因为防止本机默认启动mysql而抛出端口占用错误
environment:
TZ: Asia/Shanghai
MYSQL_ROOT_PASSWORD: "password" # defaultUser : root
MYSQL_DATABASE: "goweb"
command:
--character-set-server=utf8mb4
--collation-server=utf8mb4_general_ci
--explicit_defaults_for_timestamp=true
--lower_case_table_names=1
--max_allowed_packet=128M
# --skip-name-resolve
# --sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION,NO_ZERO_DATE,NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO"
volumes:
- ./docker-db:/var/lib/mysql
本来用的是mysql57,但是由于设备更换为M1芯片,不能启动mysql57,最终只能升级mysql,就出现了不可链接的错误;
-
解决:
- 通过
docker进入容器,mysql -uroot -p password(用户名跟密码,看我上面的配置) use mysqlupdate mysql.user set 'host' = '%' where User = 'root';flush privileges;
- 通过