1092: 输出一个整数的各位数字
Time Limit: 1 SecMemory Limit: 128 MB
Submit: 3738Solved: 1181
Description
输入一个正整数 repeat (0
输入一个整数,从高位开始逐位输出它的各位数字。
Input
输入的整数可能大于1030
Output
见sample
Sample Input
3
123456
-600
8
Sample Output
1 2 3 4 5 6
6 0 0
8
#include <stdio.h>
#include <string.h>
int main()
{
char a[200000];
int rep,e;
scanf("%d",&rep);
while(rep--){
scanf("%s",&a);
e=0;
for(int i=0;i<strlen(a);i++){
if(a[i]>='0'&&a[i]<='9')
{
if(e!=0)
printf(" ");
printf("%c",a[i]);
e=1;
}
}
printf("\n");
}
return 0;
}