第一步:
配置PC1, PC2,Server IP 地址,网关
第二步:
测试 PC1, PC2 可以相互ping通, Service 谁都不通
第三步:
配置路由器
enable
configure terminal
interface vlan 1
nameif inside
ip address 192.168.1.1 255.255.255.0
exit
interface vlan 2
nameif outside
ip address 202.112.147.1 255.255.255.0
exit
interface e0/0
switchport access vlan 1
exit
interface e0/1
switchport access vlan 2
exit
interface e0
nameif inside
security-level 100
speed 100
no shutdown
ip address 192.168.1.1 255.255.255.0
exit
interface e1
nameif outside
security-level 0
speed 100
no shutdown
ip address 202.112.147.1
exit
第四步:
测试:
PC1 PC2 能 Ping 通 192.168.1.1,不能 Ping 通 202.112.147.0 网段
Server 能 Ping 通 202.112.147.1,不能 Ping 通 192.168.1.0 网段
第五步
继续配置PAT
access-list acl extended permit icmp any any
access-list acl permit icmp any any
access-group acl in interface outside
object network outside-pat-address
host 202.112.147.5
object network inside-pat-address
subnet 192.168.1.0 255.255.255.0
nat (inside, outside) dynamic interface
ps: 这里应该可以使用vlan 设置成202.112.147.5, e0/1 设置能202.112.147.1 实现。
object network static-inside-address
host 192.168.1.11
nat (inside, outside) static 202.112.147.11
global (outside) 202.112.147.5
nat (inside) 1 192.168.1.0 255.255.255.0
static (inside, outside) 202.112.147.11 192.168.1.11
第六步
在server 端启动telnetd 服务
sudo busybox telnetd
在pc1, pc2 使用 telnet client
telnet 202.112.147.22
用户名tc, 无密码
关于展示:
大致可以分几个部分
- 七层网络模型
下四层主要功能及设备 - 常用网络相关命令
ping
tarceroute ... - 交换基础
- 网络划分及vlan
- nat (网络地址转换) pat (nat的一种)