juniper路由实例间的重分布(auto-export)

juniper不像cisco、华为有多ospf进程的概念,但是有逻辑路由器和逻辑隧道,路由实例

cisco的重分布参考:

https://costiser.ro/2013/01/10/redistribute-different-ospf-processes/

juniper路由实例间的重分布有2种办法:rib-group和auto-export

本文测试auto-export
vmx跑2个routing-instance(cust-left,cust-right)

left路由器导出外部路由lo0.0时带tag12

right路由器导出外部路由lo0.0时带tag23

目的:

left上要能学到right lo0.0的路由

right要能学到left  lo0.0的路由

拓扑:



root@left> show configuration | display set

set version 14.1R4.8

set system host-name left

set system root-authentication encrypted-password "$1$2490VjfM$UrF82MOjzmKJzOayMJyap."

set system services ssh root-login allow

set system services ssh protocol-version v2

set system syslog user * any emergency

set system syslog file messages any notice

set system syslog file messages authorization info

set system syslog file interactive-commands interactive-commands any

set interfaces ge-0/0/0 unit 0 family inet address 192.168.12.1/24

set interfaces em0 unit 0 family inet address 10.5.245.41/24

set interfaces lo0 unit 0 family inet address 1.1.1.1/32

set routing-options static route 10.5.0.0/16 next-hop 10.5.245.254

set routing-options router-id 10.5.245.41

set protocols ospf export export-tag

set protocols ospf area 0.0.0.0 interface ge-0/0/0.0

set policy-options policy-statement export-tag term disconnect-tag from interface lo0.0

set policy-options policy-statement export-tag term disconnect-tag then tag 12

set policy-options policy-statement export-tag term disconnect-tag then accept


root@right> show configuration | display set

set version 14.1R4.8

set system host-name right

set system root-authentication encrypted-password "$1$tJ618mXU$XQO1Bd2rVic9uuC46vXbR/"

set system services ssh root-login allow

set system services ssh protocol-version v2

set system syslog user * any emergency

set system syslog file messages any notice

set system syslog file messages authorization info

set system syslog file interactive-commands interactive-commands any

set interfaces ge-0/0/1 unit 0 family inet address 192.168.23.3/24

set interfaces em0 unit 0 family inet address 10.5.245.43/24

set interfaces lo0 unit 0 family inet address 3.3.3.3/32

set routing-options static route 10.5.0.0/16 next-hop 10.5.245.254

set routing-options router-id 10.5.245.43

set protocols ospf export export-tag

set protocols ospf area 0.0.0.0 interface ge-0/0/1.0

set policy-options policy-statement export-tag term disconnect-tag from interface lo0.0

set policy-options policy-statement export-tag term disconnect-tag then tag 23

set policy-options policy-statement export-tag term disconnect-tag then accept


root@vmx> show configuration | display set

set version 14.1R4.8

set system host-name vmx

set system root-authentication encrypted-password "$1$qmh0fZRG$IG64f970Vi8QJ.12FD7FR0"

set system services ssh root-login allow

set system services ssh protocol-version v2

set system syslog user * any emergency

set system syslog file messages any notice

set system syslog file messages authorization info

set system syslog file interactive-commands interactive-commands any

set interfaces ge-0/0/0 unit 0 family inet address 192.168.12.2/24

set interfaces ge-0/0/1 unit 0 family inet address 192.168.23.2/24

set interfaces em0 unit 0 family inet address 10.5.245.42/24

set interfaces lo0 unit 0 family inet address 2.2.2.2/32

set interfaces lo0 unit 1 family inet address 12.12.12.12/32

set interfaces lo0 unit 2 family inet address 23.23.23.23/32

set routing-options static route 10.5.0.0/16 next-hop 10.5.245.254

set routing-options router-id 10.5.245.42

set protocols ospf area 0.0.0.0 interface lo0.0

set policy-options policy-statement export-to-left term 1 from tag 23

set policy-options policy-statement export-to-left term 1 then accept

set policy-options policy-statement export-to-right term 1 from tag 12

set policy-options policy-statement export-to-right term 1 then accept

set policy-options policy-statement import-from-cust-left term 1 from community cust-left

set policy-options policy-statement import-from-cust-left term 1 then accept

set policy-options policy-statement import-from-cust-right term 1 from community cust-right

set policy-options policy-statement import-from-cust-right term 1 then accept

set policy-options community cust-left members target:65002:1

set policy-options community cust-right members target:65003:1

set routing-instances cust-left instance-type vrf

set routing-instances cust-left interface ge-0/0/0.0

set routing-instances cust-left interface lo0.1

set routing-instances cust-left route-distinguisher 65002:1

set routing-instances cust-left vrf-import import-from-cust-right

set routing-instances cust-left vrf-target target:65002:1

set routing-instances cust-left routing-options auto-export

set routing-instances cust-left protocols ospf export export-to-left

set routing-instances cust-left protocols ospf area 0.0.0.0 interface ge-0/0/0.0

set routing-instances cust-right instance-type vrf

set routing-instances cust-right interface ge-0/0/1.0

set routing-instances cust-right interface lo0.2

set routing-instances cust-right route-distinguisher 65003:1

set routing-instances cust-right vrf-import import-from-cust-left

set routing-instances cust-right vrf-target target:65003:1

set routing-instances cust-right routing-options auto-export

set routing-instances cust-right protocols ospf export export-to-right

set routing-instances cust-right protocols ospf area 0.0.0.0 interface ge-0/0/1.0


验证:

root@vmx> show route table cust-left.inet.0 protocol ospf

cust-left.inet.0: 9 destinations, 9 routes (9 active, 0 holddown, 0 hidden)

+ = Active Route, - = Last Active, * = Both

1.1.1.1/32        *[OSPF/150] 00:35:23, metric 0, tag 12

                    > to 192.168.12.1 via ge-0/0/0.0

3.3.3.3/32        *[OSPF/150] 00:03:17, metric 0, tag 23

                    > to 192.168.23.3 via ge-0/0/1.0

224.0.0.5/32      *[OSPF/10] 01:05:19, metric 1

                      MultiRecv

root@vmx>

root@vmx> show route table cust-right.inet.0 protocol ospf                           

cust-right.inet.0: 9 destinations, 9 routes (9 active, 0 holddown, 0 hidden)

+ = Active Route, - = Last Active, * = Both

1.1.1.1/32        *[OSPF/150] 00:35:35, metric 0, tag 12

                    > to 192.168.12.1 via ge-0/0/0.0

3.3.3.3/32        *[OSPF/150] 00:32:13, metric 0, tag 23

                    > to 192.168.23.3 via ge-0/0/1.0

224.0.0.5/32      *[OSPF/10] 01:05:31, metric 1

                      MultiRecv



root@left> show route protocol ospf

inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)

+ = Active Route, - = Last Active, * = Both

3.3.3.3/32        *[OSPF/150] 00:04:16, metric 0, tag 23

                    > to 192.168.12.2 via ge-0/0/0.0

224.0.0.5/32      *[OSPF/10] 01:28:00, metric 1

                      MultiRecv



root@right> show route protocol ospf

inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)

= Active Route, - = Last Active, * = Both

1.1.1.1/32        *[OSPF/150] 00:14:01, metric 0, tag 12

> to 192.168.23.2 via ge-0/0/1.0

224.0.0.5/32      *[OSPF/10] 01:22:18, metric 1

MultiRecv

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 217,406评论 6 503
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,732评论 3 393
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 163,711评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,380评论 1 293
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,432评论 6 392
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,301评论 1 301
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,145评论 3 418
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 39,008评论 0 276
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,443评论 1 314
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,649评论 3 334
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,795评论 1 347
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,501评论 5 345
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,119评论 3 328
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,731评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,865评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,899评论 2 370
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,724评论 2 354

推荐阅读更多精彩内容