原题目
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only:
C
- C Programming Language,M
- Mathematics (Calculus or Linear Algrbra), andE
- English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades ofC
,M
,E
andA
- Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of
C
,M
andE
. Then there are M lines, each containing a student ID.
Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered asA
>C
>M
>E
. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply outputN/A
.
Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A
题目大意
给出学生ID和每位学生三门课程的成绩和想知道自己成绩的学生ID,求各位想知道成绩的学生三门课程及平均分中排名最好的一门的名次及课程名。
输入的第一行包含两个整数N
和M
,分别表示总学生数和想知道自己成绩的学生数。之后的N行输入每名学生的ID及三门课程的成绩。接下来的M行是想查询自己成绩的学生的ID。输出M行,分别表示每位想知道自己成绩的学生的最佳排名。若该学生不在成绩表中则输出N/A
。
题解
想了半天不知道用啥数据结构来存,最后还是选择了最简单的方法,直接O(n2)遍历求得每门课程对应的排名。
为方便输入和比较,学生ID直接采用long long
型存储。
C语言代码如下:
#include<stdio.h>
#include<stdlib.h>
int n, m;
void find(long long *id, long long query, int *A, int *C, int *M, int *E){
for(int i = 0;i < n;++i){
if(id[i] == query){
int minn = n + 1;
int index;
int score[] = {A[i], C[i], M[i], E[i]};
for(int i = 0;i < 4;++i){
if(score[i] < minn){
minn = score[i];
index = i;
}
}
switch (index)
{
case 0:
printf("%d A\n", A[i]);
break;
case 1:
printf("%d C\n", C[i]);
break;
case 2:
printf("%d M\n", M[i]);
break;
case 3:
printf("%d E\n", E[i]);
break;
default:
break;
}
return;
}
}
printf("N/A\n");
}
int *rank(int *grades){
int *ret = malloc(sizeof(int) * n);
for(int i = 0;i < n;++i) ret[i] = 1;
for(int i = 0;i < n;++i){
for(int j = 0;j < n;++j){
if(grades[j] > grades[i]){
ret[i]++;
}
}
}
return ret;
}
int main(){
scanf("%d%d", &n, &m);
long long *id = malloc(sizeof(long long) * n);
long long query;
int *C = malloc(sizeof(int) * n);
int *M = malloc(sizeof(int) * n);
int *E = malloc(sizeof(int) * n);
int *A = malloc(sizeof(int) * n);
for(int i = 0;i < n;++i){
scanf("%lld%d%d%d", id + i, C + i, M + i, E + i);
A[i] = (C[i] + M[i] + E[i]) / 3;
}
int *rankA = rank(A), *rankC = rank(C), *rankM = rank(M), *rankE = rank(E);
for(int i = 0;i < m;++i){
scanf("%lld", &query);
find(id, query, rankA, rankC, rankM, rankE);
}
return 0;
}