cisco Switching-三层交换配置路由

问题

三层交换机实现了VLAN间互通后,还要与其他网络进行通信,这样就需要有相关的路由机制。

交换接口配置为三层接口实现路由间通信

方案

三层交换机既然具有三层功能,也就可以实现与路由器相似的配置。既可以把交换接口配置为三层接口,也可以在其上配置静态、动态路由。通过对三层交换机的路由配置,实现VLAN与其他网络的互通。

拓扑图

步骤

1.配置三层交换机

三层交换机创建vlan并配置vlan的虚端口IP并开启路由功能

Switch>enable

Switch#configure terminal

Switch(config)#vlan 2

Switch(config-vlan)#vlan 3

Switch(config-vlan)#vlan 4

Switch(config-vlan)#vlan 5

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.1.254 255.255.255.0

Switch(config-if)#no shutdown

Switch(config)#interface vlan 2

Switch(config-if)#ip address 192.168.2.254 255.255.255.0

Switch(config-if)#no shutdown

Switch(config)#interface vlan 3

Switch(config-if)#ip address 192.168.3.254 255.255.255.0

Switch(config-if)#no shutdown

Switch(config)#interface vlan 4

Switch(config-if)#ip address 192.168.4.254 255.255.255.0

Switch(config-if)#no shutdown

Switch(config)#interface vlan 5

Switch(config-if)#ip address 192.168.5.254 255.255.255.0

Switch(config-if)#no shutdown

Switch(config)#ip routing //开启路由功能

三层交换的Fa0/23、Fa0/24设置为中继链路模式

Switch(config)#interface range f0/23-24

Switch (config-if-range)#switchport trunk encapsulation dot1q

Switch (config-if-range)#switchport mode trunk

2.配置二层交换机

Sw1创建vlan2、 vlan3并将端口加入vlan

Sw1(config)#vlan 2

Sw1(config)#vlan 2

Sw1(config-vlan)#vlan 3

Sw1(config)#interface fastEthernet 0/2

Sw1(config-if)#switchport access vlan 2

Sw1(config)#interface fastEthernet 0/3

Sw1(config-if)#switchport access vlan 3

Sw1(config)#interface fastEthernet 0/5

Sw1(config-if)#switchport mode trunk //连接三层交换机的接口配置为trunk模式

Sw2创建vlan4、 vlan5并将端口加入vlan

Sw2(config)#vlan 4

Sw2(config-vlan)#vlan 5

Sw2(config)#interface fastEthernet 0/1

Sw2(config-if)#switchport access vlan 4

Sw2(config)#interface f0/2

Sw2(config-if)#switchport access vlan 5

3.将三层交换的Fa0/6口配置为三层路由端口,并配置IP地址

三层交换机的物理端口默认是二层端口,只具有二层特性,不能配置IP地址。把二层端口配置为三层端口后,该端口就具备路由功能了,可以配置IP地址,但同时也就关闭了其二层特性,比如不能把三层端口加入VLAN。

二层端口(交换机上的端口默认都是二层端口)默认是激活状态,那些没有使用到的端口为了安全应该手工将其禁用(shutdown);而三层端口(路由器上的端口或是三层交换机上被配置成路由端口的端口)默认是禁用状态,在使用之前务必要将其激活(no shutdown)。

Switch(config)#interface f0/6

Switch(config-if)#no switchport

Switch(config-if)#ip address 192.168.6.1 255.255.255.0

Switch(config-if)#no shutdown

4.配置路由器的端口IP地址

Switch(config)#interface f0/0

Switch(config-if)#ip address 192.168.6.2 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#interface f0/1

Switch(config-if)#ip address 192.168.7.254 255.255.255.0

Switch(config-if)#no shutdown

5.在三层交换机上配置静态路由,以便VLAN内主机可以与外界网络互联

Switch(config)#iproute 192.168.7.0 255.255.255.0 192.168.6.2 //格式 ip route 下一跳

Switch(config)#exit

Switch#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, Vlan1

C 192.168.2.0/24 is directly connected, Vlan2

C 192.168.3.0/24 is directly connected, Vlan3

C 192.168.4.0/24 is directly connected, Vlan4

C 192.168.5.0/24 is directly connected, Vlan5

C 192.168.6.0/24 is directly connected, FastEthernet0/6

S 192.168.7.0/24 [1/0] via 192.168.6.2

6.在路由器上配置到达三个VLAN网络的静路由

tarena-rouer(config)#ip route 192.168.1.0 255.255.255.0 192.168.6.1

tarena-rouer(config)#ip route 192.168.2.0 255.255.255.0 192.168.6.1

tarena-rouer(config)#ip route 192.168.3.0 255.255.255.0 192.168.6.1

tarena-rouer(config)#ip route 192.168.4.0 255.255.255.0 192.168.6.1

tarena-rouer(config)#ip route 192.168.5.0 255.255.255.0 192.168.6.1

tarena-rouer(config)#exit

tarena-rouer#show ip rout

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

S    192.168.1.0/24 [1/0] via 192.168.6.1

S    192.168.2.0/24 [1/0] via 192.168.6.1

S    192.168.3.0/24 [1/0] via 192.168.6.1

S    192.168.4.0/24 [1/0] via 192.168.6.1

S    192.168.5.0/24 [1/0] via 192.168.6.1

C    192.168.6.0/24 is directly connected, FastEthernet0/0

C    192.168.7.0/24 is directly connected, FastEthernet0/1

7.在PC上测试与VLAN的连通性

PC>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address.........: FE80::2E0:8FFF:FE14:BB43

IP Address......................: 192.168.7.1

Subnet Mask.....................: 255.255.255.0

Default Gateway.................: 192.168.7.254

SERVER>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:

Request timed out.

Reply from 192.168.1.1: bytes=32 time=0ms TTL=126

Reply from 192.168.1.1: bytes=32 time=0ms TTL=126

Reply from 192.168.1.1: bytes=32 time=1ms TTL=126

Ping statistics for 192.168.1.1:

Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 1ms, Average = 0ms

SERVER>ping 192.168.2.1

Pinging 192.168.2.1 with 32 bytes of data:

Reply from 192.168.2.1: bytes=32 time=0ms TTL=126

Reply from 192.168.2.1: bytes=32 time=0ms TTL=126

Reply from 192.168.2.1: bytes=32 time=0ms TTL=126

Reply from 192.168.2.1: bytes=32 time=0ms TTL=126

Ping statistics for 192.168.2.1:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms

SERVER>ping 192.168.3.1

Pinging 192.168.3.1 with 32 bytes of data:

Reply from 192.168.3.1: bytes=32 time=1ms TTL=126

Reply from 192.168.3.1: bytes=32 time=0ms TTL=126

Reply from 192.168.3.1: bytes=32 time=0ms TTL=126

Reply from 192.168.3.1: bytes=32 time=0ms TTL=126

Ping statistics for 192.168.3.1:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 1ms, Average = 0ms

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 194,088评论 5 459
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 81,715评论 2 371
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 141,361评论 0 319
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,099评论 1 263
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 60,987评论 4 355
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,063评论 1 272
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,486评论 3 381
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,175评论 0 253
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,440评论 1 290
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,518评论 2 309
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,305评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,190评论 3 312
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,550评论 3 298
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,880评论 0 17
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,152评论 1 250
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,451评论 2 341
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,637评论 2 335

推荐阅读更多精彩内容