PAT 甲级 刷题日记|A 1021 Deepest Root (25 分)

单词积累

acyclic 非循环的 非周期的

connected components 连通分量

题目

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5结尾无空行

Sample Output 1:

3
4
5结尾无空行

Sample Input 2:

5
1 3
1 4
2 5
3 4结尾无空行

Sample Output 2:

Error: 2 components

思路

第一个问题:判断是否为树。由于题目已经表明,只有N-1条边,所以必然是树,或者是带环路的的森林,这样问题就转换为判断连通块的个数。
第二个问题就是计算最大深度的问题,可以逐个点开始遍历,遍历过程中记录最大深度。最后排序输出。

代码

#include <bits/stdc++.h>
using namespace std;

const int maxn = 10003;
vector<vector<int>> gra;
int visit[maxn];
int depth[maxn];
int n;

struct node{
    int depth;
    int id;
}Node[maxn];

int dfs(int root, int depth) {
    int de = depth;
    visit[root] = 1;
    for (int i = 0; i < gra[root].size(); i++) {
        if (visit[gra[root][i]] == 0) {
            de = max(dfs(gra[root][i], depth + 1), de);
        }
    }
    return de;
}

int dfstra() {
    int times = 0;
    for (int i = 0; i <= n; i++) {
        visit[i] = 0; 
    } 
    for (int i = 1; i <= n; i++) {
        if (visit[i] == 0) {
            times++;
            dfs(i, 0);
        }
    }
    return times;
}

void dfstra2() {
    for (int i = 1; i <= n; i++) {
        for (int j = 0; j <= n; j++) {
            visit[j] = 0; 
        } 
        Node[i].depth = dfs(i,0);
        Node[i].id = i;
        
    }
}

bool cmp(node a, node b) {
    if (a.depth != b.depth) return a.depth > b.depth;
    return a.id < b.id;
}

int main() {
    int a, b;
    cin>>n;
    gra.resize(n+1);
    for (int i = 0; i < n - 1; i++) {
        cin>>a>>b;
        gra[a].push_back(b);
        gra[b].push_back(a);
    }
    int times = dfstra();
    if (times > 1) {
        printf("Error: %d components\n", times);
    } else {
        dfstra2();
        sort(Node + 1, Node + n + 1, cmp);
        for (int i = 1; i <= n; i++) {
            if (i != 1 && Node[i].depth != Node[i-1].depth) break;
            cout<<Node[i].id<<endl;
        }
    }
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 216,402评论 6 499
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,377评论 3 392
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 162,483评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,165评论 1 292
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,176评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,146评论 1 297
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,032评论 3 417
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,896评论 0 274
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,311评论 1 310
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,536评论 2 332
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,696评论 1 348
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,413评论 5 343
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,008评论 3 325
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,659评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,815评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,698评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,592评论 2 353

推荐阅读更多精彩内容