云盘程序server搭建备忘

1.PHP添加fileinfo扩展;

程序中使用到fileinfo相关的函数

2.Nginx配置添加cors相关配置:

云盘程序和server程序是两个域名,所以在上传的时候会涉及到跨域问题;主要是在server这边处理;
上传的时候一般会有两个请求,一个是option请求,一个是上传的post请求,需要在option请求时正常的响应,才能继续正常的上传操作,所以在配置server的ngnix环境时需要加上下列代码:

location / {
      if ($request_method = 'OPTIONS') {
        add_header 'Access-Control-Allow-Origin' "*"; 
        add_header 'Access-Control-Allow-Methods' 'GET, POST, PUT, DELETE, OPTIONS'; 
        add_header 'Access-Control-Allow-Headers' 'Origin, X-Requested-With, Content-Type, Accept, Authorization'; 
        return 200; 
      } 
    }

注意,这里的add_header一定要加在 "location /"里面,否则会报错;

3.修改上传文件大小限制

文件上传最大大小为4GB,所以需要修改服务器的上传大小限制:

  • ngnix管理-性能调整-client_max_body_size: 4096
  • PHP 上传限制 4096MB
  • server代码里面的config也需要修改最大文件大小

4.文件名中有特殊符号无法上传的问题

是因为get请求时,会将一些特殊符号(例如“+”)进行转义操作,导致两边生成的sign不匹配,导致验证失败;所以在本地生成sign之前,需要对文件名进行urldecode处理,代码如下

'name' => urldecode($file['name']),
最后编辑于 :
©著作权归作者所有,转载或内容合作请联系作者
【社区内容提示】社区部分内容疑似由AI辅助生成,浏览时请结合常识与多方信息审慎甄别。
平台声明:文章内容(如有图片或视频亦包括在内)由作者上传并发布,文章内容仅代表作者本人观点,简书系信息发布平台,仅提供信息存储服务。

相关阅读更多精彩内容

友情链接更多精彩内容