阿里云Ubuntu服务器安装Zookeeper

安装前需要先安装 JDK 安装JDK

安装 Zookeeper

  1. 官网地址
    http://zookeeper.apache.org/index.html
  2. 下载地址
    http://apache.fayea.com/zookeeper/
  3. 下载安装包
    这里需要注意 从3.5.5开始,tar.gz包里只是源码,只有bin.tar.gz包才是编译后的二进制的包。
    否则启动时会报错 Error: Could not find or load main class org.apache.zookeeper.ZooKeeperMain
    下载命令
    wget https://mirrors.tuna.tsinghua.edu.cn/apache/zookeeper/zookeeper-3.5.7/apache-zookeeper-3.5.7-bin.tar.gz
  4. 解压安装包
    tar -zxvf apache-zookeeper-3.5.7-bin.tar.gz
  5. 进入解压目录的conf目录,复制配置文件zoo_sample.cfg并命名为zoo.cfg
    cp zoo_sample.cfg zoo.cfg

修改配置

vi zoo.cfg

image.png

zookeeper 3.5+的版本之后内嵌了管理控制台,通过jetty启动,会占用8080端口
启动 zookeeper 时会报错:java.net.BindException: Address already in use
通过查看zookeeper的官方文档,发现有3种解决途径:

  1. 删除jetty;
  2. 修改端口:修改方法的方法有两种,一种是在启动脚本中增加 -Dzookeeper.admin.serverPort=你的端口号。一种是在zoo.cfg中增加admin.serverPort=没有被占用的端口号
  3. 停用这个服务:在启动脚本中增加"-Dzookeeper.admin.enableServer=false"

配置系统环境变量

vi /etc/profile
添加

export ZOOKEEPER_HOME=/root/apache-zookeeper-3.5.7-bin/
PATH=$ZOOKEEPER_HOME/bin:$PATH

使添加的配置其生效
source /etc/profile

启动 zookeeper

切换到bin目录
./zkServer.sh start

Zookeeper 命令

启动 Zookeeper:./zkServer.sh start
查看状态:./zkServer.sh status
关闭 Zookeeper:./zkServer.sh stop
查看日志(存放在logs目录):tail 日志文件名称

最后编辑于 :
©著作权归作者所有,转载或内容合作请联系作者
【社区内容提示】社区部分内容疑似由AI辅助生成,浏览时请结合常识与多方信息审慎甄别。
平台声明:文章内容(如有图片或视频亦包括在内)由作者上传并发布,文章内容仅代表作者本人观点,简书系信息发布平台,仅提供信息存储服务。

相关阅读更多精彩内容

友情链接更多精彩内容