This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
分析
这题主要注意一下输出时的多项式个数,其实单独无脑遍历统计就好..
像我这样在输入时做统计的容易碰到逻辑上的问题,就算因此可以少用一次循环也没什么好处,因为这题本身不太可能TLE
#include<iostream>
using namespace std;
int main() {
int K,exp,cnt=0;
float cof,e[1001]={0.0};
for(int i=0;i<2;i++){
cin>>K;
while(K--){
cin>>exp>>cof;
if(e[exp]==0){
cnt++;
}
e[exp]+=cof;
if(e[exp]==0){
cnt--;
}
}
}
cout<<cnt;
for(int i=1000;i>=0;i--){
if(e[i]!=0){
printf(" %d %.1f",i,e[i]);
}
}
return 0;
}