华为交换机配置vrrp、mstp综合实验

;


1.PC1的网关ip位于汇聚交换机A,PC2的网关IP位于汇聚交换机B,默认均为vlan 1;

2.核心交换机A 与核心交换机B 采用VRRP实现高可用,双机互联端口采用二层聚合;

3.核心交换机A 指定为Vlan 194 和 vlan 192 的根桥(bridge root),核心交换机B指定为vlan195 和vlan193的根桥(bridge root);

汇聚层交换机A:

#生成树的模式选为mstp

stp mode mstp

#进入生成树的配置模式

stp region-configuration

region-name yongfu

#创建实例1,将vlan192、194划到实例1中

instance 1 vlan 192 194 

#创建实例1,将vlan193、195划到实例2中

instance 2 vlan 193 195

#激活配置

active region-configuration

interface Vlanif1

#接入层交换机的网关ip

ip address 10.12.192.254 255.255.255.128

interface Vlanif192

ip address 10.13.192.156 255.255.255.248

interface Ethernet0/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

interface Ethernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#配置环回接口的IP地址

interface LoopBack0

ip address 1.1.1.1 255.255.255.0

#配置route-id 1.1.1.1

ospf 1 router-id 1.1.1.1

area 0

#宣告直连网络

  network 10.13.192.0 0.0.0.255

  network 10.12.192.128 0.0.0.127

汇聚层交换机B:

vlan batch 193

stp mode mstp

stp region-configuration

region-name yongfu

instance 1 vlan 192 194

instance 2 vlan 193 195

active region-configuration

interface Vlanif1

#pc2的网关ip

ip address 10.14.192.126 255.255.255.128

interface Vlanif193

ip address 10.13.193.156 255.255.255.248

interface Ethernet0/0/1

port link-type trunk

port trunk allow-pass vlan 193

interface Ethernet0/0/2

port link-type trunk

port trunk allow-pass vlan 193

#配置ospf,手动设置route-id

ospf 1 router-id 2.2.2.2

area 0

#宣告直连网段

  network 10.14.192.0 0.0.0.127

  network 10.13.193.152 0.0.0.7

核心交换机lsw1:

#创建vlan192-195

vlan batch 192 to 195

#指定该交换机为实例1的根网桥(即为vlan 192、194的根桥)

stp instance 1 root primary

#指定该交换机为实例2的根网桥(即为vlan 193、195的备根桥)

stp instance 2 root secondary

#配置mstp生成树协议

stp mode mstp

stp region-configuration

region-name yongfu

instance 1 vlan 192 194

instance 2 vlan 193 195

active region-configuration

interface Vlanif192

ip address 10.13.192.153 255.255.255.248

#配置vrrp协议,vrid为192,虚拟网关地址为10.13.192.155

vrrp vrid 192 virtual-ip 10.13.192.155

#默认优先级是100,现将优先级设置为120,为主网关设备

vrrp vrid 192 priority 120

interface Vlanif193

ip address 10.13.193.153 255.255.255.248

#不配置优先级,默认为100,作为备用网关

vrrp vrid 193 virtual-ip 10.13.193.155

interface Vlanif194

ip address 10.13.194.1 255.255.255.248

vrrp vrid 194 virtual-ip 10.13.194.3

vrrp vrid 194 priority 120

interface Vlanif195

ip address 10.13.195.1 255.255.255.248

vrrp vrid 195 virtual-ip 10.13.195.3

#配置聚合口

interface Eth-Trunk1

port link-type trunk

#放通所有vlan

port trunk allow-pass vlan 2 to 4094

#将接口划分为对应的vlan

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 192

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 193

#将GigabitEthernet0/0/3、GigabitEthernet0/0/4捆绑成一个聚合口

interface GigabitEthernet0/0/3

eth-trunk 1

interface GigabitEthernet0/0/4

eth-trunk 1


interface GigabitEthernet0/0/5

port link-type trunk

port trunk allow-pass vlan 2 to 4094


interface GigabitEthernet0/0/6

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#配置ospf,进程号为1,route-id为3.3.3.3

ospf 1 router-id 3.3.3.3

area 0.0.0.0

#宣告直连网段

  network 10.13.192.152 0.0.0.7

  network 10.13.193.152 0.0.0.7

  network 10.13.194.0 0.0.0.7

  network 10.13.195.0 0.0.0.7

ip route-static 19.130.107.0 255.255.255.192 10.13.194.5

核心交换机lsw2:(配置与lsw1相似)

#创建vlan192-195

vlan batch 192 to 195

stp mode mstp

stp instance 2 root primary

stp instance 1 root secondary

stp region-configuration

region-name yongfu

instance 1 vlan 192 194

instance 2 vlan 193 195

active region-configuration

#配置个接口的ip地址,配置vrrp,设置主、备网关

interface Vlanif192

ip address 10.13.192.154 255.255.255.248

vrrp vrid 192 virtual-ip 10.13.192.155

interface Vlanif193

ip address 10.13.193.154 255.255.255.248

vrrp vrid 193 virtual-ip 10.13.193.155

vrrp vrid 193 priority 120

interface Vlanif194

ip address 10.13.194.2 255.255.255.248

vrrp vrid 194 virtual-ip 10.13.194.3

interface Vlanif195

ip address 10.13.195.2 255.255.255.248

vrrp vrid 195 virtual-ip 10.13.195.3

vrrp vrid 195 priority 120

interface Eth-Trunk1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 192

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 193

interface GigabitEthernet0/0/3

eth-trunk 1

interface GigabitEthernet0/0/4

eth-trunk 1

interface GigabitEthernet0/0/5

port link-type trunk

port trunk allow-pass vlan 2 to 4094

interface GigabitEthernet0/0/6

port link-type trunk

port trunk allow-pass vlan 2 to 4094

交换机lsw14:

vlan batch 194

stp mode mstp 

stp region-configuration

region-name yongfu

instance 1 vlan 192 194

instance 2 vlan 193 195

active region-configuration

interface Vlanif1

ip address 10.13.192.133 255.255.255.252

interface Vlanif194

ip address 10.13.194.5 255.255.255.248

interface Ethernet0/0/1

port link-type trunk

port trunk allow-pass vlan 194

interface Ethernet0/0/2

port link-type trunk

port trunk allow-pass vlan 194

#配置ospf,进程号为1,route-id 5.5.5.5

ospf 1 router-id 5.5.5.5

area 0.0.0.0

  network 10.13.194.0 0.0.0.7

  network 10.13.192.132 0.0.0.3

ip route-static 19.130.107.0 255.255.255.0 10.13.192.134

交换机lsw15:

vlan batch 195

stp mode mstp

stp region-configuration

region-name yongu

instance 1 vlan 192 194

instance 2 vlan 193 195

active region-configuration

interface Vlanif1

ip address 10.13.192.149 255.255.255.252

interface Vlanif195

ip address 10.13.195.5 255.255.255.248

interface Ethernet0/0/1

port link-type trunk

port trunk allow-pass vlan 195

interface Ethernet0/0/2

port link-type trunk

port trunk allow-pass vlan 195

ospf 1 router-id 6.6.6.6

area 0.0.0.0

  network 10.13.192.148 0.0.0.3

  network 10.13.195.0 0.0.0.7

ip route-static 61.142.211.0 255.255.255.0 10.13.192.150

出口路由器R1:

interface Ethernet0/0/0

ip address 10.13.192.134 255.255.255.252

interface Ethernet0/0/1

ip address 19.130.107.1 255.255.255.0

ospf 1 router-id 7.7.7.7

area 0.0.0.0

  network 10.13.192.132 0.0.0.3

  network 19.130.107.0 0.0.0.255

ip route-static 0.0.0.0 0.0.0.0 10.13.192.133

出口路由器R2:


interface Ethernet0/0/0

ip address 10.13.192.150 255.255.255.252

interface Ethernet0/0/1

interface GigabitEthernet0/0/0

ip address 61.142.211.122 255.255.255.0

nat static global 61.142.211.123 inside 10.12.194.1 netmask 255.255.255.255

nat static enable

ospf 1 router-id 8.8.8.8

area 0.0.0.0

  network 10.13.192.148 0.0.0.3

  network 61.142.211.0 0.0.0.255

ip route-static 0.0.0.0 0.0.0.0 10.13.192.149

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 214,029评论 6 493
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,238评论 3 388
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 159,576评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,214评论 1 287
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,324评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,392评论 1 292
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,416评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,196评论 0 269
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,631评论 1 306
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,919评论 2 328
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,090评论 1 342
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,767评论 4 337
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,410评论 3 322
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,090评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,328评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,952评论 2 365
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,979评论 2 351