Prometheus 更换 labels tag 后,Grafana 出现 Multiple Series Error 错误

Grafana 使用 Prometheus 做数据源时,当在 Prometheus 中把 Labels 从 instance="10.1.0.176" service="prod" 更换为 instance="10.1.0.176" service="Linux" 后,


Grafana Singlestat 图表出现 Multiple Series Error 错误

原因是 Grafana Singlestat 只支持 1 个输出值,而 node_memory_MemTotal_bytes{instance=~"$node"} 查询会同时取到
node_memory_MemTotal_bytes{instance=~"$node",job="Linux Host",service="Linux"}node_memory_MemTotal_bytes{instance=~"$node",job="Linux Host",service="prod"} 的值,所以会出现错误

解决办法:
指定只获取 node_memory_MemTotal_bytes{instance=~"$node",job="Linux Host",service="Linux"} 的值,就正常了

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
【社区内容提示】社区部分内容疑似由AI辅助生成,浏览时请结合常识与多方信息审慎甄别。
平台声明:文章内容(如有图片或视频亦包括在内)由作者上传并发布,文章内容仅代表作者本人观点,简书系信息发布平台,仅提供信息存储服务。

友情链接更多精彩内容