实验2-2-4 计算分段函数[2] (10 分)
1. 题目摘自
https://pintia.cn/problem-sets/13/problems/398
2. 题目内容
本题目要求计算下列分段函数f(x)的值:
注:可在头文件中包含math.h
,并调用sqrt
函数求平方根,调用pow
函数求幂。
输入格式:
输入在一行中给出实数x。
输出格式:
在一行中按“f(x) = result”的格式输出,其中x与result都保留两位小数。
输入样例1:
10
输出样例1:
f(10.00) = 3.16
输入样例2:
-0.5
输出样例2:
f(-0.50) = -2.75
3. 源码参考
#include<iostream>
#include<iomanip>
#include<math.h>
using namespace std;
int main()
{
double x;
cin>>x;
if(x<0)
{
cout<<"f("<<fixed<<setprecision(2)<<x<<") = "<<pow(x+1,2)+2*x+1/x<<endl;
}
else
{
cout<<"f("<<fixed<<setprecision(2)<<x<<") = "<<pow(x,0.5)<<endl;
}
return 0;
}