poj2236 Wireless Network

题目:

Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 1. "O p" (1 <= p <= N), which means repairing computer p. 2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

题意是有N台电脑坏了,需要维修,而修好的电脑之间如果距离小于等于D,它们就可以连通,而两台电脑之间可以借助第三台电脑连接。O代表维修电脑,S代表检测两台电脑是否连通,是就输出SUCCESS,否则就输出FAIL.

由于每台电脑都有坐标,因此可以算出两两之间的距离。判断是否连接就得先知道这两台电脑是否都已经修好,可以用一个数组存储修好的电脑的编号。

由于要判断是否连通,就等价于判断两台电脑是否属于同一个集合,因此可以用并查集,先将每一台修好的电脑与之前已修好的电脑的距离求出,符合的话就加入对应的集合。
最后判断两台电脑是否属于同一个集合,是就能连通,否则就无法连通。

参考代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#define N 1005
using namespace std;
struct point {
    int x,y;
}p[N];
int repaired[N];
int par[N],ranki[N];
void init(int n) {
    for (int i = 1;i <= n;++i) {
        par[i] = i;
        ranki[i] = 0;
    }
}
double distp(int x1,int x2,int y1,int y2) {
    double d1;
    d1 = sqrt((double)((x1-x2)*(x1-x2)) + (double)((y1-y2)*(y1-y2)));
    return d1;
}
int find(int x) {
    if (par[x] == x) return x;
    else return par[x] = find(par[x]);  
}
void unite(int x,int y) {
    int fx = find(x);
    int fy = find(y);
    if (fx == fy) return;
    if (ranki[fx] > ranki[fy]) par[fy] = fx;
    else {
        par[fx] = fy;
        if (ranki[fx] == ranki[fy]) ranki[fy]++;
    }
}
int main() {
    int n,d;
    while (cin >> n >> d) {
        memset(p,0,sizeof(p));
        for (int i = 1;i <= n;++i) {
            cin >> p[i].x >> p[i].y;
        }
        init(n);
        char op;
        int num1;
        int nump,numq;
        int cnt = 1;
        while (cin >> op) {
            if (op == 'O') {
                cin >> num1;
                for (int i = 1;i <= cnt;++i) {
                    double dis = distp(p[repaired[i]].x,p[num1].x,p[repaired[i]].y,p[num1].y);
                    if (dis <= (double)(d)) {
                        unite(repaired[i],num1);
                    }
                }
                repaired[cnt++] = num1;
            }
            else if (op == 'S') {
                cin >> nump >> numq;
                nump = find(nump);
                numq = find(numq);
                if (nump == numq) cout << "SUCCESS" << endl;
                else cout << "FAIL" << endl;    
            }
        }
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 212,185评论 6 493
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 90,445评论 3 385
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 157,684评论 0 348
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 56,564评论 1 284
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 65,681评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 49,874评论 1 290
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,025评论 3 408
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,761评论 0 268
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,217评论 1 303
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,545评论 2 327
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,694评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,351评论 4 332
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,988评论 3 315
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,778评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,007评论 1 266
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,427评论 2 360
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,580评论 2 349

推荐阅读更多精彩内容