Balloon Comes!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32087 Accepted Submission(s): 12060**</font>
Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
Sample Input
4
- 1 2
- 1 2
- 1 2
/ 1 2
</pre>
Sample Output
3
-1
2
0.50
</pre>
Author
lcy
Recommend
We have carefully selected several similar problems for you: 1061 1021 1008 1108 1005
AC代码:
#include<stdio.h>
#include "string.h"
int main()
{
int i,x,y,m;
double sum;
char c[10];
scanf("%d",&m);
for ( i=0;i<m;i++)
{
scanf("%s",&c);
scanf("%d%d",&x,&y);
if (c[0]=='+')
{
sum=x+y;
printf("%d\n",x+y);
}
else if (c[0]=='-')
{
sum=x-y;
printf("%d\n",x-y);
}
else if (c[0]=='*')
{
sum=x*y;
printf("%d\n",x*y);
}
else if (c[0]=='/')//注意这里的坑,如果不能整除的情况
{
if (x%y)//不能为0的时候
{
printf("%.2f\n",x*1.0/y);//注意需要乘以1.0
}
else
printf("%d\n",x/y);
}
}
}