PAT 甲级 刷题日记|A 1114 Family Property (25 分)

单词积累

decimal 小数的,十进制的

descending 下降的

ascending 上升的,增长的

the total number of sets of the real estate under his/her name 其名下房产的总套数

题目

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1⋯Childk Mestate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; child's of his/her children; Mestate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVGsets AVGarea

where ID is the smallest ID in the family; M is the total number of family members; AVGsets is the average number of sets of their real estate; and AVGarea is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
结尾无空行

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
结尾无空行

思路

很典型的并查集题目,就是元素过多,处理起来较麻烦。比起在union过程中处理元素值,更简单的做法是合并完全部遍历计算。

此外还涉及到了排序,格式化输出等知识点。

最坑的点是默认id编号是从1开始的,居然导致了三个样例出错,检查了半天,牢记不要想当然,题目不指名,就是从0开始编。

代码

#include <bits/stdc++.h>
using namespace std;

const int maxn = 10000;
int father[maxn];
int numbers[maxn];
int visit[maxn];
double sets[maxn];
double areas[maxn];

struct fam{
    int id;
    int number;
    double sets;
    double areas;
}Family[maxn];

bool cmp(fam a, fam b) {
    if (a.areas == b.areas) return a.id < b.id;
    else return a.areas > b.areas;
}

void inital() {
    for (int i = 0; i < maxn; i++) {
        father[i] = i;
        numbers[i] = 1;
        visit[i] = 0;
        sets[i] = 0;
        areas[i] = 0;
    }
    return;
}

int findfather(int x) {
    while (x != father[x]) {
        x = father[x];
    }
    return x;
}

void Union(int a, int b) {
    visit[a] = 1;
    visit[b] = 1;
    int x = findfather(a);
    int y = findfather(b);
    if (x == y) return ;
    else if (x < y) {
        father[y] = x;
    } else if (x > y) {
        father[x] = y;
    }
    return ;
}

int main() {
    inital(); 
    int N;
    cin>>N;
    for (int i = 0; i < N; i++) {
        int id, idf, idm, idnc;
        double estate, area;
        cin>>id>>idf>>idm>>idnc;
        if (idf != -1) Union(id, idf);
        if (idm != -1) Union(id, idm);
        int idc[6];
        for (int j = 0; j < idnc; j++) {
            cin>>idc[j];
            Union(id, idc[j]);
        }
        cin>>estate>>area;
        visit[id] = 1;
        sets[id] += estate;
        areas[id] += area;
    }
    for (int i = 1; i < maxn; i++) {
        if(sets[i] != 0 || areas[i] != 0) {
            int fa = findfather(i);
            if (i != fa) {
                sets[fa] += sets[i];
                areas[fa] += areas[i];
            }
        }
    }
    int clus = 0;
    for (int i = 0; i < maxn; i++) {
        if(i != father[i]) {
            int fa = findfather(i);
            numbers[fa]++;
        }
    }
    for (int i = 0; i < maxn; i++) {
        if(i == father[i] && visit[i] != 0) {
            Family[clus].id = i;
            Family[clus].number = numbers[i];
            Family[clus].sets = (double)(sets[i] * 1.0)/numbers[i];
            Family[clus].areas= (double)(areas[i] * 1.0)/numbers[i];
            clus++;
        }
    }
    sort(Family, Family+clus, cmp);
    cout<<clus<<endl;
    for (int i = 0; i < clus; i++) {
        printf("%04d %d %.3f %.3f\n", Family[i].id, Family[i].number, Family[i].sets, Family[i].areas);
    }
} 
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 216,402评论 6 499
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,377评论 3 392
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 162,483评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,165评论 1 292
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,176评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,146评论 1 297
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,032评论 3 417
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,896评论 0 274
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,311评论 1 310
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,536评论 2 332
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,696评论 1 348
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,413评论 5 343
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,008评论 3 325
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,659评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,815评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,698评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,592评论 2 353

推荐阅读更多精彩内容