单词积累
even 偶数
odd 奇数
Eulerian path 欧拉路径
connected graph 连通图
题目
In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).
Output Specification:
For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either Eulerian
, Semi-Eulerian
, or Non-Eulerian
. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
结尾无空行
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
结尾无空行
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
结尾无空行
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
结尾无空行
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
结尾无空行
Sample Output 3:
3 3 4 3 3
Non-Eulerian
结尾无空行
思路
发现图论题的一大难点在读题。
本题的意思为,在图论中,欧拉路径是经过图中每条边有且只有一次的路径。类似的,欧拉环路是指开始和结束于同一个顶点的欧拉路径。有理论证明了,如果连通图的所有顶点的度都为偶数,则其构成了欧拉回路。如果连通图只有两个顶点的度为奇数,则其构成半欧拉回路,否则,就不是欧拉回路。
所以关键点1:判断是否为连通图,dfs
关键点2:记录每个点的度。
代码
#include <bits/stdc++.h>
using namespace std;
vector<vector<int>> v;
vector<bool> visit;
int cnt = 0;
void dfs(int root) {
cnt++;
visit[root] = true;
for (int i = 0; i < v[root].size(); i++) {
if (visit[v[root][i]] == false) {
// cout<<v[root][i]<<",,";
dfs(v[root][i]);
}
}
}
int main() {
int n, m, a, b, even = 0;
cin>>n>>m;
v.resize(n + 1);
visit.resize(n + 1);
for (int i = 0; i <= n; i++) {
visit[i] = false;
}
while (m--) {
cin>>a>>b;
v[a].push_back(b);
v[b].push_back(a);
}
for (int i = 1; i <= n; i++) {
cout<<v[i].size();
if (i != n) cout<<" ";
else cout<<endl;
if (v[i].size() % 2 != 1) {
even++;
}
}
dfs(1);
if (cnt == n && even == n) {
cout<<"Eulerian"<<endl;
} else if (cnt == n && n - even == 2) {
cout<<"Semi-Eulerian"<<endl;
} else {
cout<<"Non-Eulerian"<<endl;
}
}