我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo。
题目
Calculate and output the sum in standard format -- that is, the digits
must be separated into groups of three by commas (unless there are less than
four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers
and where . The numbers are separated by a
space.
Output Specification:
For each test case, you should output the sum of and in one line. The
sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
思路
2018/1/5更新0:重要参考链接
Stack overflow有一个帖子专门讨论如何做这个事情,我自己想到的三个也都是问题里几个高票答案的方法,大家可以学习一下。
两个要点:
- 两数和为0时要输出0;
- 注意逗号的输出位置,如不要在数字前面和后面有输出
2018/1/5更新1:
又看了一遍题,总感觉之前的代码太繁琐,就改了一个方法,使用字符串处理。
得到a和b后,将两者之和输入到一个字符串中去,使用sprintf
函数。
只需要从后向前,每三个数字判断一下是否需要加逗号即可。
2018/1/5更新2:
还有一种更省事的方法,甚至C语言里都有直接的方法处理这种事情。那就是<locale.h>头文件,这个头文件可以处理不同地区或者语言的输出方式,其中就有对数字的处理。具体细节可查看相关资料,代码放在下面
#include <stdio.h>
#include <locale.h>
int main(void)
{
setlocale(LC_NUMERIC, "");
printf("%'d\n", 1123456789);
return 0;
}
代码
最新代码@github,欢迎交流
#include <stdio.h>
#include <string.h>
int main()
{
int a, b, pos;
char num[11];
scanf("%d%d", &a, &b);
sprintf(num, "%d", a + b);
for(pos = strlen(num) - 3; pos > 0 && num[pos - 1] != '-'; pos -= 3)
{
memmove(num + pos + 1, num + pos, strlen(num) - pos + 1);
num[pos] = ',';
}
puts(num);
return 0;
}