[PAT]A1017(Queueing at Bank)解题思路&测试点分析

原题回顾

PAT_A1017原文链接

1017 Queueing at Bank (25分)

作者: CHEN, Yue
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB
代码长度限制: 16 KB

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.
Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤104) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.
Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

解题思路及注意点

  • 首先想到的是用简单模拟来做,模拟时间递增,以秒为单位。其中有几点需要特别注意:
  1. 模拟截止时间并非17:00,而是在17:00及之前来的客户全部离开等待区之时,否则测试点5将会不通过,该测试点就包含在17:00之前到达但是处理时间拖到了17:01以后;
  2. 在17:00之前来的客户,不论在等待区等到什么时候,银行总会等到为其服务,等待时间必须加到结果之中,即时是一万年也要等。
  • 第二种就是用排序来解决,将窗口服务时间列为数组,每次通过排序来得到最早服务的窗口,通过判断客户到达时间与窗口服务时间的关系来计算等待时间。这里的截止条件只有判断客户的到达时间是否超过17:00,而与客户的业务开始处理时间无关。

代码部分

模拟:

#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 10010;

struct record
{
    int hh, mm, ss;
    int process;
} rec[maxn], temp;

int n, k; //总人数,窗口数
int realN = 0; //实际服务人数
queue<record> line; //等待区队列
int waitTime = 0; //等待总时间
int window[110];  //窗口当前用户剩余处理时间,0为无用户

bool cmp(record a, record b) //将数据按照到达的时间排序
{
    if (a.hh != b.hh)
        return a.hh < b.hh;
    else if (a.mm != b.mm)
        return a.mm < b.mm;
    else
        return a.ss < b.ss;
}

void get_ans()
{
    int hh = 0, mm = 0, ss = 0; //时,分,秒
    int st = 0; //当前第一位到达的人编号
    bool isWindow; //是否有空窗口
    while ((hh < 17 || mm < 0 || ss < 0) || !line.empty())
    {
        // 银行关门之前或者排队队列为空
        ss++; //当前时间+1s
        isWindow = false;
        for (int i = 0; i < k; i++) //如果窗口有人则处理时间--,有空窗口则isWindow置为true
        {
            if (window[i] > 0)
            {
                window[i]--;
            }
            if (window[i] == 0)
                isWindow = true;
        }
        if (ss == 60)
        {
            ss = 0;
            mm++;
        }
        if (mm == 60)
        {
            mm = 0;
            hh++;
        }
        if (hh == rec[st].hh && mm == rec[st].mm && ss == rec[st].ss && (hh < 17 || mm < 0 || ss < 0))
        {
            // 在17:00之前有人到达银行
            line.push(rec[st]); //进入排队队列
            realN++; //实际处理人数++
            st++; //到达的人编号++
        }
        if (hh > 7 && isWindow == true && !line.empty())
        {
            // 到营业时间,有空窗口,有人排队
            for (int i = 0; i < k; i++) //找到空窗口,等待区进入窗口
            {
                if (window[i] == 0 && !line.empty())
                {
                    window[i] = line.front().process * 60;
                    line.pop();
                }
            }
        }
        waitTime += line.size(); //当前等待区的总等待时间(总等待人数*1s)
    }
}

int main()
{
    scanf("%d%d", &n, &k);
    for (int i = 0; i < n; i++)
    {
        scanf("%d:%d:%d", &rec[i].hh, &rec[i].mm, &rec[i].ss);
        scanf("%d", &rec[i].process);
    }
    sort(rec, rec + n, cmp);
    fill(window, window + 110, 0);
    get_ans();
    printf("%.1f\n", waitTime / 60.0 / realN);
    return 0;
}

排序:

//PAT_A1017
#include <iostream>
#include <vector>
#include <cstdio>
#include <algorithm>
using namespace  std;
const int maxn = 1010;
struct node {
    int st;
    int wt;
    node(int _st, int _wt):st(_st), wt(_wt){}
};
bool cmp (node a, node b) {
    return a.st < b.st;
}
vector<node> customer;
vector<int> window;

int main () {
    int n, k, num = 0;
    double ans = 0.0;
    scanf("%d%d", &n, &k);
    for (int i = 0; i < n; i++) {
        int h, m, s, st, wt;
        scanf("%d:%d:%d %d", &h, &m, &s, &wt);
        st = h * 60 * 60 + m * 60 + s;
        //wt = (wt > 60 ? 60 : wt); //处理超过一个小时的一律压缩至一小时,不过测试点中没有体现
        wt *= 60;
        customer.push_back(node(st, wt));
    }
    sort(customer.begin(), customer.end(), cmp);
    for (int i = 0; i < k; i++) { //初始化窗口服务时间,均为8:00
        window.push_back(8 * 60 * 60);
    }
    for (int i = 0; i < n; i++, num++) {
        sort(window.begin(), window.end()); //取当前窗口服务结束的最早时间放至首位
        if (customer[i].st > 17 * 60 * 60) { //break条件只有客户到达时间是否超过17:00,与客户开始处理的时间无关
            break;
        }
        if (customer[i].st < window[0]) { //早于窗口服务时间到达
            ans += window[0] - customer[i].st; //加上等待时间
        }
        if (customer[i].st < window[0]) {
            window[0] = window[0] + customer[i].wt; //下次窗口服务时间为当前窗口服务结束时间加上该等待用户的处理时间
        } else {
            window[0] = customer[i].st + customer[i].wt; //当前有空余窗口,下次服务时间为客户到达时间加处理时间,无需等待
        }
    }
    ans /= 60.0 * num;
    printf("%.1f", ans);
    return 0;
}

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,590评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 86,808评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 151,151评论 0 337
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,779评论 1 277
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,773评论 5 367
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,656评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,022评论 3 398
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,678评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 41,038评论 1 299
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,659评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,756评论 1 330
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,411评论 4 321
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,005评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,973评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,203评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,053评论 2 350
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,495评论 2 343

推荐阅读更多精彩内容

  • By clicking to agree to this Schedule 2, which is hereby ...
    qaz0622阅读 1,427评论 0 2
  • Java多线程与并发-基础篇 1.线程池 首先简单来介绍一下Executor。Executor 框架是 jdk1....
    课间指针阅读 745评论 0 1
  • 烈焰红唇,女人的细腰西装革履,男人的钞票这个城市,到处都是卖弄风情的虚荣舞池中央,是让人们嫉妒的小丑自尊向高贵低下...
    单芙曦阳阅读 475评论 9 19
  • 文/星拾 18岁,你在干什么? 我在奋笔疾书,3年高考,5年模拟 18岁,你喜欢什么? 我喜欢偶像剧中的男主,梦想...
    星拾阅读 382评论 0 4
  • 她走后 我的内心从未有人涉足 直到 遇见了你 我内心的冰山才开始融化 你的出现 让我的世界 从此 多了几分绿意 未...
    夕阳风暴阅读 311评论 0 5