1151.LCA in a Binary Tree

题目描述

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A.if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

考点

1.两种遍历可以唯一地确定一棵树;
2.如何追溯最小公共父结点。

思路

1.需要建树吗?
先序遍历输出的是每个根结点,中序遍历可以确定结点的相对位置。因此不需要建树就可以得知两个结点的相对关系。
2.递归实现
判断根结点与两个结点的相对位置关系,如果两个结点都在根结点的左边,那么它们的最小公共父结点一定在根节点的左子树上;在右边的情况类似。如果分别位居左右,那么这个根节点就是两个结点的最小父结点。
3.具体实现
(1)需要一个pos记录每个输入结点的相对位置,这样便于进行相对位置的比较,同时也有助于判断输入结点是否在这棵树中;
(2)pos的数据类型选择使用map,键值对有助于查询,同时mapint类型默认值为0;
(3)在每次判别之后都需要对查询范围以及根结点的值进行更新,查询范围[s, e]根据定位进行缩小,如果在左边那么范围更新为[s, root-1],在右边则更新为[root+1, e]
根结点的值根据先序遍历preOrder的输出变化,初始值即为先序遍历第一个值key=1,此后如果在根结点的左边,那么下一个根结点为key=key+1;由于先序遍历的遍历顺序为:根、左、右,在遍历右子树之前一定遍历完了左子树,因此如果在根结点的右边,那么下一个根结点为key=key+1+(root-s),跳过左子树的部分以减少时耗。

代码

#include <iostream>
#include <vector>
#include <map>
using namespace std;
vector<int> inOrder, preOrder;
map<int, int> pos;
void LCA(int s, int e, int key, int a, int b) {
    if (s > e) {
        return;
    }
    int inRoot = pos[preOrder[key]], aIn = pos[a], bIn = pos[b];
    if (aIn < inRoot&&bIn < inRoot) {
        LCA(s, inRoot - 1, key+1, a, b);
    }
    else if (aIn > inRoot&&bIn > inRoot) {
        LCA(inRoot + 1, e, key + 1+(inRoot-s), a, b);
    }
    else if ((aIn<inRoot&&bIn>inRoot) || (bIn<inRoot&&aIn>inRoot)) {
        cout << "LCA of " << a << " and " << b << " is " << inOrder[inRoot] << "." << endl;
    }
    else if (aIn == inRoot) {
        cout << a << " is an ancestor of " << b << "." << endl;
    }
    else if (bIn = inRoot) {
        cout << b << " is an ancestor of " << a << "." << endl;
    }
}
int main() {
    int M, N;
    cin >> M;cin >> N;
    inOrder.resize(N+1);preOrder.resize(N+1);
    for (int i = 1; i <= N; i++) {
        cin >> inOrder[i];
        pos[inOrder[i]] = i;
    }
    for (int i = 1; i <= N; i++) {
        cin >> preOrder[i];
    }
    //test
    for (int i = 0; i < M; i++) {
        int a, b;
        cin >> a;
        cin >> b;
        if (pos[a] == 0&&pos[b]==0) {
            cout << "ERROR: " << a << " and " << b << " are not found." << endl;
        }
        else if (pos[a] == 0||pos[b] == 0) {
            cout << "ERROR: " << (pos[a] == 0 ? a : b) << " is not found." << endl;
        }
        else {
            LCA(1, N, 1, a, b);
        }
    }
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 217,406评论 6 503
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,732评论 3 393
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 163,711评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,380评论 1 293
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,432评论 6 392
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,301评论 1 301
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,145评论 3 418
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 39,008评论 0 276
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,443评论 1 314
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,649评论 3 334
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,795评论 1 347
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,501评论 5 345
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,119评论 3 328
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,731评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,865评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,899评论 2 370
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,724评论 2 354

推荐阅读更多精彩内容