Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
5
) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
坑别较多emmm 第一次做的时候用链表做的 用string来存储地址,想这样创建聊表,发现插入是个大问题,换用vector ,但vector也不好解决。看了下别人的思路,可以用hash的思想 把结点地址单独存储,把data和next组成结构体。
一开始审题没审清楚,看例子值交换了一组 实际要交换 n/k个组
把data和next放到结构体数组中,让结点组成一个结构体数组,通过数组存储的结点地址来访问就好了
#include <iostream>
#include <algorithm>
// 一开始写成了10000 测试的时候老是溢出--
#define MAXSIZE 100000
using namespace std;
struct LNode
{
int data;
int next;
}node[MAXSIZE];
int List[MAXSIZE];
int main()
{
int h_address, n, k;
cin >> h_address >> n >> k;
int address, data, next;
for(int i = 0; i < n; i++)
{
cin >> address;
cin >> data;
cin >> next;
node[address].data = data;
node[address].next = next;
}
int end = 0;
int p = h_address;
// 用List存储node中结点的地址
while(p!=-1)
{
List[end++] = p;
p = node[p].next;
}
int first = 0;
while (first + k <= end)
{
reverse(&List[first], &List[first + k]);
first += k;
}
for(first = 0; first < end-1; first++)
printf("%05d %d %05d\n", List[first], node[List[first]].data, List[first + 1]);
printf("%05d %d -1\n", List[first], node[List[first]].data);
return 0;
}
然后就AC了