题目描述
Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^5 ). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.
Output Specification:
Print in a line the smallest positive integer that is missing from the input list.
Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7
代码
#include <iostream>
#include <vector>
using namespace std;
bool isprime(int x) {
for (int i = 2; i*i <= x; i++)
if (x % i == 0) return false;
return true;
}
int main() {
int msize, n, m, temp, addr;
cin >> msize >> n >> m;
while (!isprime(msize)) msize++;
vector<int> ht(msize);
for (int i = 0; i < n; i++) {
int flag=0;
cin >> temp;
for (int j = 0; j < msize; j++) {
addr = (temp + j*j) % msize;
if (ht[addr] == 0) {
ht[addr] = temp;
flag = 1;
break;
}
}
if (flag == 0) printf("%d cannot be inserted.\n", temp);
}
int cnt = 0;
for (int i = 0; i < m; i++) {
cin >> temp;
for (int j = 0; j <= msize; j++) {
cnt++;
addr = (temp + j*j) % msize;
if (ht[addr] == temp || ht[addr] == 0) break;
}
}
printf("%.1lf\n", cnt*1.0 / m);
return 0;
}