题目描述
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:
- Itai nyan~ (It hurts, nyan~)
- Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai
.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
思路
求解所有串的最长公共后缀。
由于是求解后缀,因此先将串逆序,然后一边输入一边两两比较。将公共部分存至ans
中,最后再将串逆序输出。
代码
#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
int main() {
int n;
scanf("%d\n", &n);
string s, ans;
for (int i = 0; i < n; i++) {
int j = 0, k = 0;
getline(cin, s);
reverse(s.begin(), s.end());
if (i == 0) {
ans = s;
continue;
}
else {
while (j < s.length() && k < ans.length() && s[j] == ans[k]) {
j++;
k++;
}
ans = s.substr(0, j);
}
}
reverse(ans.begin(), ans.end());
if (ans.size() == 0) ans = "nai";
cout << ans;
return 0;
}