贪心算法
Crixalis's Equipment
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 34 Accepted Submission(s) : 14
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.
Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines
contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
Output
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
Sample Input
2
20 3
10 20
3 10
1 7
10 2
1 10
2 11
Sample Output
Yes
No
分析:
搬的时候所占体积为b[i],
搬完后减少a[i]
先搬A,瞬间占用空间最大为 a1+b2;
先搬B,瞬间占用空间最大为a2+b1.
为了使剩下的体积最大,我们要选择这两个所占体积最小的
当a1+b2,a2+b1相等时,应该选a更小的
代码如下:
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
int a;
int b;
};
int cmp(node x,node y)
{
if(x.a+x.b==y.a+y.b)
return x.a<y.a;
return x.b-x.a>y.b-y.a;
}
int main()
{
int t,v,n,i=0;
node h[1005];
cin>>t;
while(t--)
{
cin>>v>>n;
for( i=0;i<n;i++)
{
cin>>h[i].a>>h[i].b;
}
sort(h,h+n,cmp);
for( i=0;i<n;i++)
{
if(v>=h[i].b)
{
v-=h[i].a;
}
else break;
}
if(i==n)
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
}