PAT甲级1034 Head of a Gang (并查集)

1034 Head of a Gang (30 分)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

思路

题目的大致意思是在一堆通话记录中寻找可能的帮派头目,如果直接或间接通话的人数超过两个,并且总通话时长超过K就认为是一个帮派。直接套并查集模版就可以了,如果两个人通过话就把他们并起来,并更新每个人的通话时长,最后再统计每个帮派的通话时长,需要注意的是,题目中的N是指通话的记录一共有N条,所以总人数可能达到2 \times N,如果数组不开到2000的话测试点三会WA掉。另一种方法就是使用dfs或者bfs计算连通分量的数目,下面我只给出并查集的代码。

#include <iostream>
#include <unordered_map>
#include <algorithm>
#include <string>
#include <vector>
#define MAXN 2005
using namespace std;
struct herd{
    string name;
    int num = 0, time = 0, maxtime = 0;
}herds[MAXN];
unordered_map<string, int>ump;
unordered_map<int, string>IdName;
vector<herd>res;
int fa[MAXN], times[MAXN]; //times表示每个人的通话时长
bool cmp(herd a, herd b){return a.name < b.name;}
int find(int x){
    int a = x;
    while(x != fa[x])x = fa[x];
    while(a != fa[a]){
        int tep = a;
        a = fa[a];
        fa[tep] = x;
    }
    return x;
}
void Union(int a, int b){
    int faA = find(a), faB = find(b);
    if(faA != faB)fa[faA] = faB;
}
int main(){
    int n, k, time, idx = 0;
    string name1, name2;
    scanf("%d %d", &n, &k);
    for(int i = 0; i < n * 2; i++)fa[i] = i;
    for(int i = 0; i < n; i++){
        cin >> name1 >> name2 >> time;
        if(ump.count(name1) == 0){
            ump[name1] = idx;
            IdName[idx++] = name1;
        }
        if(ump.count(name2) == 0){
            ump[name2] = idx;
            IdName[idx++] = name2;
        }
        Union(ump[name1], ump[name2]);
        times[ump[name1]] += time;
        times[ump[name2]] += time;
    }
    for(int i = 0; i < idx; i++){
        int fai = find(i);
        herds[fai].num++;
        herds[fai].time += times[i];
        if(times[i] > herds[fai].maxtime){
            herds[fai].maxtime = times[i];
            herds[fai].name = IdName[i];
        }
    }
    for(int i = 0; i < n; i++)if(herds[i].num > 2 && (herds[i].time / 2) > k)res.push_back(herds[i]);
    if(res.size() == 0){printf("%d\n", 0); return 0;}
    else{
        sort(res.begin(), res.end(), cmp);
        printf("%d\n", res.size());
        for(int i = 0; i < res.size(); i++){
            cout << res[i].name << " " << res[i].num << endl;
        }
    }
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 214,837评论 6 496
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,551评论 3 389
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 160,417评论 0 350
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,448评论 1 288
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,524评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,554评论 1 293
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,569评论 3 414
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,316评论 0 270
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,766评论 1 307
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,077评论 2 330
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,240评论 1 343
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,912评论 5 338
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,560评论 3 322
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,176评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,425评论 1 268
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,114评论 2 366
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,114评论 2 352

推荐阅读更多精彩内容