source
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
题意:按照字典顺序,如果骑士可以只经过每个点一次,且游完整个盘,则输出路径,否则输出"impossible"
题解:按题意应该用DFS来做;需要注意字典顺序;
#include<cstdio>
#include<iostream>
#include<string.h>
using namespace std;
int to[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
pair<int,char> paths[26*26];
int vis[26][26];
int l,w,flag;
bool isBad(int x,int y)
{
return (x<0)||(x>=l)||(y<0)||(y>=w)||vis[x][y];
}
void DFS(int x,int y,int step)
{
if(step==l*w)
{
flag=1;
for(int i=0;i<step;i++)
printf("%c%d",paths[i].second,paths[i].first);
printf("\n\n");
}
for(int i=0;i<8;i++)
{
int dx=x+to[i][0],dy=y+to[i][1];
if(isBad(dx,dy)) continue;
vis[dx][dy]=1;
paths[step].first=dx+1;
paths[step].second=(char)(dy+65);
DFS(dx,dy,step+1);
vis[dx][dy]=0;
if(flag) return;
}
}
int main()
{
int T;
scanf("%d",&T);
for(int i=1;i<=T;i++)
{
flag=0;
memset(vis,0,sizeof(vis));
scanf("%d%d",&l,&w);
vis[0][0]=1;
paths[0].first=1;
paths[0].second='A';
printf("Scenario #%d:\n",i);
DFS(0,0,1);
if(!flag){
printf("impossible\n\n");
}
}
}