记一次生产esxi centos7进入紧急修复模式无法启动问题

由于客户的服务器突然断电,导致ESXi中的某个centos7虚拟机无法启动
报错信息如下:

image.png

报错:Internal error XFS_WANT_CORRUPTED_GOTO at line 1635 of file fs/xfs/libxfs/xfs_alloc.c.

【解决方法】
在ESXi虚拟机控制台输入密码进入系统,执行以下命令

# 查看 /home所在分区
fdisk -l
# 修复分区
xfs_repair -L /dev/mapper/centos-home
# 重启系统
init 6

参考:
https://blog.csdn.net/Chenftli/article/details/125537240

©著作权归作者所有,转载或内容合作请联系作者
【社区内容提示】社区部分内容疑似由AI辅助生成,浏览时请结合常识与多方信息审慎甄别。
平台声明:文章内容(如有图片或视频亦包括在内)由作者上传并发布,文章内容仅代表作者本人观点,简书系信息发布平台,仅提供信息存储服务。

相关阅读更多精彩内容

友情链接更多精彩内容