题目:
61:双端队列
总时间限制: 1000ms 内存限制: 65535kB
描述
定义一个双端队列,进队操作与普通队列一样,从队尾进入。出队操作既可以从队头,也可以从队尾。编程实现这个数据结构。
输入
第一行输入一个整数t,代表测试数据的组数。
每组数据的第一行输入一个整数n,表示操作的次数。
接着输入n行,每行对应一个操作,首先输入一个整数type。
当type=1,进队操作,接着输入一个整数x,表示进入队列的元素。
当type=2,出队操作,接着输入一个整数c,c=0代表从队头出队,c=1代表从队尾出队。
n <= 1000
输出
对于每组测试数据,输出执行完所有的操作后队列中剩余的元素,元素之间用空格隔开,按队头到队尾的顺序输出,占一行。如果队列中已经没有任何的元素,输出NULL。
样例输入
2
5
1 2
1 3
1 4
2 0
2 1
6
1 1
1 2
1 3
2 0
2 1
2 0
样例输出
3
NULL
typedef struct _node{
int* a;//数据用数组存取
int rear;//队尾
int front;//队头
}*dQueue;
int num;
scanf("%d",&num);
myQueue->a[myQueue->rear++]=num;
int next;
scanf("%d",&next);
if(next==0){//从队头取出
myQueue->front++;
}
else{ //从队尾取出
myQueue->rear--;
}
#include <stdio.h>
#include <stdlib.h>
typedef struct _node{
int* a;
int rear;//队尾
int front;//队头
}*dQueue;
int main()
{
int m;
scanf("%d",&m);
while(m--){
int n;
scanf("%d",&n);
dQueue myQueue=(dQueue)malloc(sizeof(struct _node));
myQueue->rear=0;
myQueue->front=0;
myQueue->a=(int*)malloc(sizeof(int)*n);//最多做n次插入操作,所以最大也只需要申请n*int大的空间
while(n--){
int order;
scanf("%d",&order);
switch(order){
case 1:{
int num;
scanf("%d",&num);
myQueue->a[myQueue->rear++]=num;
break;
}
case 2:{
int next;
scanf("%d",&next);
if(next==0){//从队头取出元素
myQueue->front++;
}
else{//从队尾取出元素
myQueue->rear--;
}
break;
}
}
}
if(myQueue->front==myQueue->rear)//判断队列是否为空
printf("NULL\n");
else{
for(int i=myQueue->front;i<myQueue->rear;i++){
printf("%d ",myQueue->a[i]);
}
printf("\n");
}
}
return 0;
}