男人八题之 POJ 1742

题目

男人八题Coins

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 
Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output

For each test case output the answer on a single line.
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output

8
4

具体的意思就是每组数据包含 n 中硬币,表的最大可能的价格是 m,A1,A2,A3...An 分别代表每种硬币的价值,C2,C3...Cn 代表每种硬币的数量。求一共有多少种可能的价格。就是个背包问题。

代码

#include <stdio.h>
#include <iostream>
#include <bitset>
using namespace std;

int main(int argc, const char * argv[]) {
    int n, m;

    // 每种硬币的价值
    int value[105];

    // 每种硬币的数量
    int number[105];

    // 价格的可能性,比如价格 i,如果 bitset 第 i 位为 true,则代表此价格可行,反之则不可行。
    bitset<100005> resultBitSet;
    
    while (true) {

        // 处理数据的输入
        scanf("%d %d", &n, &m);
        if (n == 0 && m == 0) {
            return 0;
        }
        for (int i = 0; i < n; i++) {
            scanf("%d", &value[i]);
        }
        for (int i = 0; i < n; i++) {
            scanf("%d", &number[i]);
        }
        
        // 重置 resultBitSet
        resultBitSet.reset();

        // 从存钱罐中挨个取硬币处理
        for (int i = 0; i < n; i++) {
            for (int t = 1; t <= number[i] && t*value[i] <= m; t++) {
                // 最关键的两行代码,<< 计算的是新增的可能价值,|= 是在原有可能价值的基础上累加新增的可能价值
                resultBitSet |= (resultBitSet << value[i]);

                // 这行其实也挺关键的,做初始化,如果这行代码顺序出错也是得不出正确结果的
                resultBitSet.set(t*value[i]);
            }
        }
        
        // 以上的 for 循环在移位时会计算进部分超过 m 价值的数据,这里通过移位把这些数据移掉
        resultBitSet <<= (100005 - (m + 1));

        printf("%lu\n", resultBitSet.count());
    }
}

其实一直想找这样一个可以直接移位的内存块,这样处理起来就很方便了。不过说来惭愧,虽然 13 年左右写过一年的 C++,但是不知道是当时就不知道 bitset 还是后来这几年不写给忘了,反正就是没想起来,所以我一开始写的代码是如下的(Time Limit Exceeded):

#include <stdio.h>
#include<iostream>
#include <cstring>

int value[105];
int number[105];

bool result[100005];

// 处理输入
bool processInput(int &n, int &m) {
    scanf("%d %d", &n, &m);
    if (n == 0 && m == 0) {
        return false;
    }
    for (int i = 0; i < n; i++) {
        scanf("%d", &value[i]);
    }
    for (int i = 0; i < n; i++) {
        scanf("%d", &number[i]);
    }
    return true;
}

// 计算结果
void calculate(int n, int m) {
    memset(result, 0, sizeof(result));
    
    for (int i = 0; i < n; i++) {
        if (number[i] <= m) {
            for (int k = m; k >= 1; k--) {
                if (result[k] && k + value[i] <= m) {
                    for (int t = 1; t <= number[i] && k + t * value[i] <= m; t++) {
                        result[k + t * value[i]] = true;
                    }
                }
            }
            for (int t = 1; t <= number[i] && t*value[i] <= m; t++) {
                result[t*value[i]] = true;
            }
        }
    }
}

int main(int argc, const char * argv[]) {
    int n, m;
    while (processInput(n, m)) {
        calculate(n, m);
        int total = 0;
        for (int i = 1; i <= m; i++) {
            if (result[i]) {
                total++;
            }
        }
        printf("%d\n", total);
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 213,928评论 6 493
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,192评论 3 387
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 159,468评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,186评论 1 286
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,295评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,374评论 1 292
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,403评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,186评论 0 269
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,610评论 1 306
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,906评论 2 328
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,075评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,755评论 4 337
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,393评论 3 320
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,079评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,313评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,934评论 2 365
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,963评论 2 351

推荐阅读更多精彩内容