习题8-5 使用函数实现字符串部分复制 (20 分)
1. 题目摘自
https://pintia.cn/problem-sets/12/problems/338
2. 题目内容
本题要求编写函数,将输入字符串t中从第m个字符开始的全部字符复制到字符串s中。
函数接口定义:
void strmcpy( char *t, int m, char *s );
函数strmcpy将输入字符串char *t中从第m个字符开始的全部字符复制到字符串char *s中。若m超过输入字符串的长度,则结果字符串应为空串。
输入样例:
7
happy new year
输出样例:
new year
3. 源码参考
#include<iostream>
using namespace std;
#define MAXN 20
void strmcpy(char *t, int m, char *s);
void ReadString(char s[]);
int main()
{
char t[MAXN], s[MAXN];
int m;
scanf("%d\n", &m);
ReadString(t);
strmcpy(t, m, s);
printf("%s\n", s);
return 0;
}
void ReadString(char s[])
{
cin.getline(s, MAXN);
return;
}
void strmcpy(char *t, int m, char *s)
{
int n = strlen(t);
if (m < n) {
for (int i = 0; i <= n - m; i++) {
s[i] = t[m + i - 1];
}
}
return;
}